<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>AEROSMITH Joins Forces With RUN-DMC For Performance At 2020 Grammy Awards - Bravewords.com</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="news, hard rock, aerosmith, run-dmc">
    <meta name="description" content="The Recording Academy recently confirmed performers for the 62nd Annual Grammy Awards, including MusiCares Person Of The Year Aerosmith, who will perform a medley of some of their legendary hits.
Variety is now reporting that, according to a source close to the situation, Run-DMC will perform with Aerosmith at...">
    <meta name="author" content="bravewords.com">
    <meta name="verify-v1" content="UG2Z0A6uZRfu/o3aZh9WaxJSVUDm4RZbqJrFe/F7Mis=" />
    <meta name="alexaVerifyID" content="S1M8-AaHKAG76rKFC1bczMy8KvM" />
    <meta name="bitly-verification" content="444d87609be9" />
    
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="AEROSMITH Joins Forces With RUN-DMC For Performance At 2020 Grammy Awards" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://bravewords.com/news/aerosmith-joins-forces-with-run-dmc-for-performance-at-2020-grammy-awards" />
<meta property="og:image" content="http://bravewords.com/medias-static/images/news/2020/5E1F22B2-aerosmith-joins-forces-with-run-dmc-for-performance-at-2020-grammy-awards-image.jpeg" />
<meta property="og:description" content="The Recording Academy recently confirmed performers for the 62nd Annual Grammy Awards, including MusiCares Person Of The Year Aerosmith, who will perform a medley of some of their legendary hits.
Variety is now reporting that, according to a source close to the situation, Run-DMC will perform with Aerosmith at..." />
<meta property="og:site_name" content="bravewords.com" />
<meta property="article:publisher" content="https://www.facebook.com/bravewords" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="hard rock" />
<meta property="article:tag" content="aerosmith" />
<meta property="article:tag" content="run-dmc" />
<meta property="fb:app_id" content="684233228278895" />

    
<meta name="twitter:card" content="summary">
<meta property="twitter:url" content="http://bravewords.com/news/aerosmith-joins-forces-with-run-dmc-for-performance-at-2020-grammy-awards" />
<meta name="twitter:site" content="@BraveWords666">
<meta name="twitter:domain" content="bravewords.com">
<meta name="twitter:title" content="AEROSMITH Joins Forces With RUN-DMC For Performance At 2020 Grammy Awards">
<meta name="twitter:description" content="The Recording Academy recently confirmed performers for the 62nd Annual Grammy Awards, including MusiCares Person Of The Year Aerosmith, who will perform a medley of some of their legendary hits.
Variety is now reporting that, according to a source close to the situation, Run-DMC will perform with Aerosmith at...">
<meta name="twitter:creator" content="@BraveWords666">
<meta name="twitter:image" content="http://bravewords.com/medias-static/images/news/2020/5E1F22B2-aerosmith-joins-forces-with-run-dmc-for-performance-at-2020-grammy-awards-image.jpeg">

    <!-- Bootstrap -->
    <link href="/assets-static/vendors.0bff35fbc4d494b9cd40.css" rel="stylesheet">
    <link href="/assets-static/app.0bff35fbc4d494b9cd40.css" rel="stylesheet">
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 10]>
      <script src="//cdn.jsdelivr.net/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="//cdn.jsdelivr.net/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <link rel="shortcut icon" href="/app-static/favicon.png">
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS News Channel" href="http://bravewords.com/rss/news.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Reviews Channel" href="http://bravewords.com/rss/reviews.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Features Channel" href="http://bravewords.com/rss/features.xml"/>
    

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f148a0f143921a1" async="async"></script>
<script src="https://Q1MediaHydraPlatform.com/ads/video/controller.php?qid=588f5a2956c2586c325b9421&qz=1" async></script>
<script async id="aniviewJS892590094" src="https://play.aniview.com/56f146aa181f467d0a8b45c1/5b7d522c28a0616498072cbb/bravewords_Floater.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/bravewords/loader.js');
</script>
<script src="https://cdn.reignn.com/Clients/Publishers/70318/Sites/Bravewords.com/Bravewords.com.js"></script>
<script type="text/javascript">
var $BWCategory = 'news';
var $BWTags = ['news', 'hard rock', 'aerosmith', 'run-dmc'];
var $BWContentType = 'article';
var $BWTargetDomain = 'www.revolvermag.com';
</script>
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/29ac4385-3ca7-4db1-853a-ce2ff340f9f9.js');/*]]>*/</script>

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-342765-2', 'auto');
      ga('send', 'pageview');
    </script>
    <script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//connect.facebook.net/en_US/all.js"></script>
  </head>
  <body id="root">
    <div id="pace-loader"></div>

    



<div id="bw-takeover" class="takeover"></div>

<section id="header" data-region="header">
  <div class="container container-defaults header">
    <div class="row">
      <div id="top-logo" class="col-sm-6 col-sm-offset-3">
        <div class="top-logo">
          <a href="http://bravewords.com/home">
            <img src="/assets-static/img/bravewords-350.png">
          </a>
        </div>
      </div>
      <div id="top-nav" class="col-sm-3">
        <ul class="top-nav">
          <li>
            <a href="https://www.facebook.com/bravewords">
              <i class="fa fa-facebook"></i>
            </a>
          </li>
          <li>
            <a href="https://twitter.com/bravewords666">
              <i class="fa fa-twitter"></i>
            </a>
          </li>
          <li>
            <a href="https://www.instagram.com/bravewords666">
              <i class="fa fa-instagram"></i>
            </a>
          </li>
          <li>
            <a href="https://www.youtube.com/user/BraveWords666">
              <i class="fa fa-youtube"></i>
            </a>
          </li>
        </ul>
      </div>
    </div>
    <div class="row">
      <div class="leaderboard">
        <div id="bw-leaderboard"></div>
      </div>
    </div>
  </div>
</section>

<section id="main-nav" class="afflix" data-spy="afflix">
  <div class="container container-defaults">
    <nav class="navbar navbar-inverse" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
        </button>
        <div class="navbar-brand">
          <div class="nav-logo">
            <img src="/assets-static/img/bw.png">
          </div>
        </div>
      </div>

      <!-- Collect the nav links, forms, and other content for toggling -->
      <div class="collapse navbar-collapse" id="navbar-collapse">
        <ul class="nav navbar-nav navbar-main">
          <li class=""><a href="/home">Home</a></li>
          <li class="dropdown active">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">News <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/news">Latest News</a></li>
              <li><a href="/news?t=heavy+metal">Heavy Metal</a></li>
              <li><a href="/news?t=black+death">Black Death</a></li>
              <li><a href="/news?t=hard+rock">Hard Rock</a></li>
              <li><a href="/news?t=classic+rock">Classic Rock</a></li>
              <li><a href="/news?t=riff+notes">Riff Notes</a></li>
              <li><a href="/news?t=rarities">Rarities</a></li>
            </ul>
          </li>
          <li class=""><a href="/reviews">Reviews</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Medias <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/galleries">Galleries</a></li>
              <li><a href="/videos">Videos</a></li>
              <li><a href="/exclusives/videos">Featured Videos</a></li>
              <li><a href="/exclusives/audios/player">Featured Audios</a></li>
            </ul>
          </li>
          <li class=""><a href="/metal-market">Market</a></li>
          <li class=""><a href="http://bb.bravewords.com">Board</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">About <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/about/contact">Contact</a></li>
              <li><a href="/about/who-we-are">Who We Are</a></li>
              <li><a href="/about/how-to-advertise">How To Advertise</a></li>
            </ul>
          </li>
        </ul>
        <ul class="nav navbar-nav navbar-right navbar-search">
          <li class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
              <i class="fa fa-search search-icon"></i>
            </a>
            <div class="dropdown-menu dropdown-search">
              <form
                class="navbar-form navbar-right"
                role="search"
                action="http://bravewords.com/search"
                >
                <div>
                  <input
                    type="text"
                    class="form-control input-md global-search"
                    name="q"
                    placeholder="SEARCH"
                    >
                </div>
              </form>
            </div>
          </li>
        </ul>
      </div>
    </nav>
  </div>
</section>

<section id="content" data-region="body">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 content">
        

<div class="row">
  <div class="col-md-8 page-content">
    <div class="clearfix">
      <h2 class="page-title">AEROSMITH Joins Forces With RUN-DMC For Performance At 2020 Grammy Awards</h2>
      <p class="page-publish-on">January 15, 2020, an hour ago</p>
      <p class="page-tags">
        <span class="label label-default label-gray-light">news</span>
        <span class="label label-default label-gray-light">hard rock</span>
        <span class="label label-default label-gray-light">aerosmith</span>
        <span class="label label-default label-gray-light">run-dmc</span>
      </p>
      <div class="addthis_sharing_toolbox pull-right"></div>
    </div>
    <div class="page-body">
      <img class="img-responsive page-image" src="/medias-static/images/news/2020/5E1F22B2-aerosmith-joins-forces-with-run-dmc-for-performance-at-2020-grammy-awards-image.jpeg" alt="AEROSMITH Joins Forces With RUN-DMC For Performance At 2020 Grammy Awards">
      <p>The Recording Academy recently confirmed performers for the 62nd Annual Grammy Awards, including MusiCares Person Of The Year Aerosmith, who will perform a medley of some of their legendary hits.</p>

<p><a href="https://variety.com/2020/music/news/run-dmc-aerosmith-grammy-awards-exclusive-1203467311/" target="_blank">Variety</a> is now reporting that, according to a source close to the situation, Run-DMC will perform with Aerosmith at the Grammy Awards on January 26. The duo are not expected to perform with the Boston group for their entire set - which makes it seem likely that the band will perform a career-spanning medley, as artists often do on the show, and Run-DMC will join them for “Walk This Way".</p>

<p>Live from Staples Center, and hosted by Alicia Keys, the 62nd Annual Grammy Awards will be broadcast live in HDTV and 5.1 surround sound on the CBS Television Network, Sunday, January 26 at 8 PM, ET/5 PM, PT.</p>

<p><img alt="" src="/medias-static/images/news/2020/aerogrammy120.jpeg" style="width: 640px; height: 337px;" /></p>

<p>Four-time Grammy-winning band Aerosmith first performed on the Grammy stage on the 33rd Grammy Awards in 1991. This year, they are appearing as the MusiCares Person Of The Year, being recognized for their considerable philanthropic efforts over five decades and undeniable impact on American music history.</p>

<p><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/4B_UYYPb-Gk" width="600"></iframe></p>

      <br clear="all">
      
<br clear="all">
<div id="zergnet-widget-70729"></div>
<script language="javascript" type="text/javascript">
  (function() {
    var zergnet = document.createElement('script');
    zergnet.type = 'text/javascript'; zergnet.async = true;
    zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=70729';
    var znscr = document.getElementsByTagName('script')[0];
    znscr.parentNode.insertBefore(zergnet, znscr);
  })();
</script>

      
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

    </div>
    <div id="bw-content-box" class="bw-ads"></div>
    
<div class="disqus-widget">
  <div id="disqus_thread"></div>
</div>

  </div>
  <div class="col-md-4 shared-col">
    
<div class="shared-column">
  <div id="bw-shared-box"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Audio</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="http://bravewords.com/exclusives/audios/player">
        <img src="/medias-static/audios/2019/SepulturaIsolation.jpg" alt="SEPULTURA – “Isolation” (Nuclear Blast)" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        SEPULTURA – “Isolation” (Nuclear Blast)
      </h4>
    </div>
  </div>
</div>

  <div id="bw-shared-medium"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Video</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="/exclusives/videos/bleed-the-sky-premieres-serpent">
        <img src="/medias-static/audios/2020/BleedTheSkyThisWayLiesMadness.jpg" alt="BLEED THE SKY Premieres &#34;Serpent&#34;" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        BLEED THE SKY Premieres &#34;Serpent&#34;
      </h4>
    </div>
  </div>
  <div>
    <a class="btn btn-link btn-brand btn-read-more pull-right" href="http://bravewords.com/exclusives/videos">View More</a>
  </div>
</div>

  <div id="bw-shared-small"></div>
  
<div class="panel bw-panel stories-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Latest <span class="text-bold">Reviews</span></h3>
  </div>
  <div class="panel-body">
    <ul class="stories-list">
      <li class="story-media">
        <a class="story-left-image" href="/reviews/come-on-feel-the-noize-the-story-of-how-rock-became-metal">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/ComeOnFeelTheNoizethumb.jpg" alt="COME ON FEEL THE NOIZE – The Story Of How Rock Became Metal">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/come-on-feel-the-noize-the-story-of-how-rock-became-metal">COME ON FEEL THE NOIZE – The Story Of How Rock Became Metal</a>
          </h5>
          <p class="story-published-on">January 14, 2020, 17 hours ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">come on feel the noize</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/magic-kingdom-metalmighty">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/MagicKingdomMetAlmightythumb.jpg" alt="MAGIC KINGDOM – MetAlmighty">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/magic-kingdom-metalmighty">MAGIC KINGDOM – MetAlmighty</a>
          </h5>
          <p class="story-published-on">January 13, 2020, 2 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">magic kingdom</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/konvent-puritan-masochism">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/KonventPuritanMasochismthumb.jpg" alt="KONVENT – Puritan Masochism">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/konvent-puritan-masochism">KONVENT – Puritan Masochism</a>
          </h5>
          <p class="story-published-on">January 11, 2020, 3 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">konvent</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/doctor-pheabes-army-of-the-sun">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/DoctorPheabesArmyOfTheSunthumb.jpg" alt="DOCTOR PHEABES – Army Of The Sun">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/doctor-pheabes-army-of-the-sun">DOCTOR PHEABES – Army Of The Sun</a>
          </h5>
          <p class="story-published-on">January 9, 2020, 5 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">doctor pheabes</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/trenchlung-hiraeth">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/HiraethTrenchlungthumb.jpg" alt="TRENCHLUNG - Hiraeth">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/trenchlung-hiraeth">TRENCHLUNG - Hiraeth</a>
          </h5>
          <p class="story-published-on">January 8, 2020, 6 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">trenchlung</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/ricardo-s-amorim-wolves-who-were-men-the-history-of-moonspell">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/MoonspellWolvesWhoWereMenthumb.jpg" alt="RICARDO S. AMORIM - Wolves Who Were Men: The History Of MOONSPELL">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/ricardo-s-amorim-wolves-who-were-men-the-history-of-moonspell">RICARDO S. AMORIM - Wolves Who Were Men: The History Of MOONSPELL</a>
          </h5>
          <p class="story-published-on">January 7, 2020, 7 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">moonspell</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/wildire-smokin">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/WildfireSmokinthumb.jpg" alt="WILDIRE - Smokin&#39;">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/wildire-smokin">WILDIRE - Smokin&#39;</a>
          </h5>
          <p class="story-published-on">January 5, 2020, 9 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">rarities</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/angel-sword-neon-city">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/AngelSwordNeonCitythumb.jpg" alt="ANGEL SWORD - Neon City">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/angel-sword-neon-city">ANGEL SWORD - Neon City</a>
          </h5>
          <p class="story-published-on">January 4, 2020, 10 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">angel sword</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/blood-incantation-hidden-history-of-the-human-race">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/BloodIncantationHiddenHistorythumb.jpg" alt="BLOOD INCANTATION - Hidden History Of The Human Race">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/blood-incantation-hidden-history-of-the-human-race">BLOOD INCANTATION - Hidden History Of The Human Race</a>
          </h5>
          <p class="story-published-on">December 29, 2019, 16 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">blood incantation</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/michael-sweet-ten">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/MichaelSweetTenthumb.jpg" alt="MICHAEL SWEET - Ten">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/michael-sweet-ten">MICHAEL SWEET - Ten</a>
          </h5>
          <p class="story-published-on">December 27, 2019, 18 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">micahel sweet</span>
          </p>
        </div>
      </li>
      <li class="story-read-more">
        <a class="btn btn-link btn-brand btn-read-more" href="http://bravewords.com/reviews">Read More</a>
      </li>
    </ul>
  </div>
</div>

  

<br clear="all">
<div>
<script
  type="text/javascript"
  language="javascript"
  src="https://live.sekindo.com/live/liveView.php?s=99959&cbuster=1579104940&pubUrl=http%3A%2F%2Fbravewords.com%2Fnews%2Faerosmith-joins-forces-with-run-dmc-for-performance-at-2020-grammy-awards&x=300&y=250&vp_content=plembed146erlohukmv&vp_template=5888&subId=[SUBID_ENCODED]">
</script>
</div>

  
<br clear="all">
<div id="insticator-container">
  <div id="div-insticator-ad-1" adonis-marker></div>
  <div id="insticator-embed" embed-id="c9e2d7ce-e545-4ad6-9ace-ef50b2853f4d"></div>
  <div id="div-insticator-ad-2" adonis-marker></div>
  <script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "c9e2d7ce-e545-4ad6-9ace-ef50b2853f4d"});/*]]>*/</script>
</div>

  <br clear="all">
</div>

  </div>
</div>

        <br clear="all">
        <div id="zergnet-widget-70730"></div>
        <script language="javascript" type="text/javascript">
          (function() {
            var zergnet = document.createElement('script');
            zergnet.type = 'text/javascript'; zergnet.async = true;
            zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=70730';
            var znscr = document.getElementsByTagName('script')[0];
            znscr.parentNode.insertBefore(zergnet, znscr);
          })();
        </script>
      </div>
    </div>
  </div>
</section>

<section id="footer" data-region="footer">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 footer">
        
  bravewords.com • <a href="/terms-and-conditions">Terms & Conditions</a>

      </div>
    </div>
  </div>
</section>

<div id="modal" class="modal" data-region="modal"></div>


    <script src="/assets-static/vendors.0bff35fbc4d494b9cd40.js"></script>
    <script src="/assets-static/app.0bff35fbc4d494b9cd40.js"></script>
    
    <!--- UNDERDOGMEDIA EDGE_BraveWords.com JavaScript ADCODE START--->
    <script data-cfasync="false" language="javascript" async src="//udmserve.net/udm/img.fetch?sid=13687;tid=1;dt=6;"></script>
    <!--- UNDERDOGMEDIA EDGE_BraveWords.com JavaScript ADCODE END--->
  </body>
</html>




