<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>CYHRA Comment On North American Tour Debut - &#34;SABATON And KREATOR Fans Embraced Us With Love; The Venues Were Full From The Start&#34; (Video) - Bravewords.com</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="news, cyhra, amaranthe, in flames, kreator, sabaton, heavy metal">
    <meta name="description" content="Antihero Magazine had the chance to sit down with Jake E and Euge Valovirta of CyHra during their recent North American tour with Sabaton and Kreator. They discussed the band’s first major tour since the release of their debut record, Letters To Myself, their instant on-stage chemistry, plans for...">
    <meta name="author" content="bravewords.com">
    <meta name="verify-v1" content="UG2Z0A6uZRfu/o3aZh9WaxJSVUDm4RZbqJrFe/F7Mis=" />
    <meta name="alexaVerifyID" content="S1M8-AaHKAG76rKFC1bczMy8KvM" />
    <meta name="bitly-verification" content="444d87609be9" />
    
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="CYHRA Comment On North American Tour Debut - &#34;SABATON And KREATOR Fans Embraced Us With Love; The Venues Were Full From The Start&#34; (Video)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://bravewords.com/news/cyhra-comment-on-north-american-tour-debut-sabaton-and-kreator-fans-embraced-us-with-love-the-venues-were-full-from-the-start-video" />
<meta property="og:image" content="http://bravewords.com/medias-static/images/news/2018/5AA8F83A-cyhra-comment-on-north-american-tour-debut-sabaton-and-kreator-fans-embraced-us-with-love-the-venues-were-full-from-the-start-video-image.jpg" />
<meta property="og:description" content="Antihero Magazine had the chance to sit down with Jake E and Euge Valovirta of CyHra during their recent North American tour with Sabaton and Kreator. They discussed the band’s first major tour since the release of their debut record, Letters To Myself, their instant on-stage chemistry, plans for..." />
<meta property="og:site_name" content="bravewords.com" />
<meta property="article:publisher" content="https://www.facebook.com/bravewords" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="cyhra" />
<meta property="article:tag" content="amaranthe" />
<meta property="article:tag" content="in flames" />
<meta property="article:tag" content="kreator" />
<meta property="article:tag" content="sabaton" />
<meta property="article:tag" content="heavy metal" />
<meta property="fb:app_id" content="684233228278895" />

    
<meta name="twitter:card" content="summary">
<meta property="twitter:url" content="http://bravewords.com/news/cyhra-comment-on-north-american-tour-debut-sabaton-and-kreator-fans-embraced-us-with-love-the-venues-were-full-from-the-start-video" />
<meta name="twitter:site" content="@BraveWords666">
<meta name="twitter:domain" content="bravewords.com">
<meta name="twitter:title" content="CYHRA Comment On North American Tour Debut - &#34;SABATON And KREATOR Fans Embraced Us With Love; The Venues Were Full From The Start&#34; (Video)">
<meta name="twitter:description" content="Antihero Magazine had the chance to sit down with Jake E and Euge Valovirta of CyHra during their recent North American tour with Sabaton and Kreator. They discussed the band’s first major tour since the release of their debut record, Letters To Myself, their instant on-stage chemistry, plans for...">
<meta name="twitter:creator" content="@BraveWords666">
<meta name="twitter:image" content="http://bravewords.com/medias-static/images/news/2018/5AA8F83A-cyhra-comment-on-north-american-tour-debut-sabaton-and-kreator-fans-embraced-us-with-love-the-venues-were-full-from-the-start-video-image.jpg">

    <!-- Bootstrap -->
    <link href="/assets-static/vendors.121dfc00550765bd7777.css" rel="stylesheet">
    <link href="/assets-static/app.121dfc00550765bd7777.css" rel="stylesheet">
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 10]>
      <script src="//cdn.jsdelivr.net/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="//cdn.jsdelivr.net/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <link rel="shortcut icon" href="/app-static/favicon.png">
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS News Channel" href="http://bravewords.com/rss/news.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Reviews Channel" href="http://bravewords.com/rss/reviews.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Features Channel" href="http://bravewords.com/rss/features.xml"/>
    

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f148a0f143921a1" async="async"></script>
<script src="https://Q1MediaHydraPlatform.com/ads/video/controller.php?qid=588f5a2956c2586c325b9421&qz=1" async></script>

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-342765-2', 'auto');
      ga('send', 'pageview');
    </script>
    <script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//connect.facebook.net/en_US/all.js"></script>
    <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({article:'auto'});
      !function (e, f, u) {
        e.async = 1;
        e.src = u;
        f.parentNode.insertBefore(e, f);
      }(document.createElement('script'),
      document.getElementsByTagName('script')[0],
      '//cdn.taboola.com/libtrc/bravewords/loader.js');
    </script>

  </head>
  <body id="root">
    <div id="pace-loader"></div>
    



<div id="bw-takeover" class="takeover"></div>

<section id="header" data-region="header">
  <div class="container container-defaults header">
    <div class="row">
      <div id="top-logo" class="col-sm-6 col-sm-offset-3">
        <div class="top-logo">
          <a href="http://bravewords.com/home">
            <img src="/assets-static/img/bravewords-350.png">
          </a>
        </div>
      </div>
      <div id="top-nav" class="col-sm-3">
        <ul class="top-nav">
          <li>
            <a href="https://www.facebook.com/bravewords">
              <i class="fa fa-facebook"></i>
            </a>
          </li>
          <li>
            <a href="https://twitter.com/bravewords666">
              <i class="fa fa-twitter"></i>
            </a>
          </li>
          <li>
            <a href="#">
              <i class="fa fa-youtube"></i>
            </a>
          </li>
        </ul>
      </div>
    </div>
    <div class="row">
      <div class="leaderboard">
        <div id="bw-leaderboard"></div>
      </div>
    </div>
  </div>
</section>

<section id="main-nav" class="afflix" data-spy="afflix">
  <div class="container container-defaults">
    <nav class="navbar navbar-inverse" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
        </button>
        <div class="navbar-brand">
          <div class="nav-logo">
            <img src="/assets-static/img/bw.png">
          </div>
        </div>
      </div>

      <!-- Collect the nav links, forms, and other content for toggling -->
      <div class="collapse navbar-collapse" id="navbar-collapse">
        <ul class="nav navbar-nav navbar-main">
          <li class=""><a href="/home">Home</a></li>
          <li class="dropdown active">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">News <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/news">Latest News</a></li>
              <li><a href="/news?t=heavy+metal">Heavy Metal</a></li>
              <li><a href="/news?t=black+death">Black Death</a></li>
              <li><a href="/news?t=hard+rock">Hard Rock</a></li>
              <li><a href="/news?t=classic+rock">Classic Rock</a></li>
              <li><a href="/news?t=riff+notes">Riff Notes</a></li>
              <li><a href="/news?t=rarities">Rarities</a></li>
            </ul>
          </li>
          <li class=""><a href="/reviews">Reviews</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Medias <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/galleries">Galleries</a></li>
              <li><a href="/videos">Videos</a></li>
              <li><a href="/exclusives/videos">Featured Videos</a></li>
              <li><a href="/exclusives/audios/player">Featured Audios</a></li>
            </ul>
          </li>
          <li class=""><a href="/metal-market">Market</a></li>
          <li class=""><a href="http://bb.bravewords.com">Board</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">About <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/about/contact">Contact</a></li>
              <li><a href="/about/who-we-are">Who We Are</a></li>
              <li><a href="/about/how-to-advertise">How To Advertise</a></li>
            </ul>
          </li>
        </ul>
        <ul class="nav navbar-nav navbar-right navbar-search">
          <li class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
              <i class="fa fa-search search-icon"></i>
            </a>
            <div class="dropdown-menu dropdown-search">
              <form
                class="navbar-form navbar-right"
                role="search"
                action="http://bravewords.com/search"
                >
                <div>
                  <input
                    type="text"
                    class="form-control input-md global-search"
                    name="q"
                    placeholder="SEARCH"
                    >
                </div>
              </form>
            </div>
          </li>
        </ul>
      </div>
    </nav>
  </div>
</section>

<section id="content" data-region="body">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 content">
        

<div class="row">
  <div class="col-md-8 page-content">
    <div class="clearfix">
      <h2 class="page-title">CYHRA Comment On North American Tour Debut - &#34;SABATON And KREATOR Fans Embraced Us With Love; The Venues Were Full From The Start&#34; (Video)</h2>
      <p class="page-publish-on">March 14, 2018, an hour ago</p>
      <p class="page-tags">
        <span class="label label-default label-gray-light">news</span>
        <span class="label label-default label-gray-light">cyhra</span>
        <span class="label label-default label-gray-light">amaranthe</span>
        <span class="label label-default label-gray-light">in flames</span>
        <span class="label label-default label-gray-light">kreator</span>
        <span class="label label-default label-gray-light">sabaton</span>
        <span class="label label-default label-gray-light">heavy metal</span>
      </p>
      <div class="addthis_sharing_toolbox pull-right"></div>
    </div>
    <div class="page-body">
      <img class="img-responsive page-image" src="/medias-static/images/news/2018/5AA8F83A-cyhra-comment-on-north-american-tour-debut-sabaton-and-kreator-fans-embraced-us-with-love-the-venues-were-full-from-the-start-video-image.jpg" alt="CYHRA Comment On North American Tour Debut - &#34;SABATON And KREATOR Fans Embraced Us With Love; The Venues Were Full From The Start&#34; (Video)">
      <p>Antihero Magazine had the chance to sit down with Jake E and Euge Valovirta of CyHra during their recent North American tour with Sabaton and Kreator. They discussed the band’s first major tour since the release of their debut record, Letters To Myself, their instant on-stage chemistry, plans for the summer, and the possibility of new music later this year.</p>

<p><iframe allow="autoplay; encrypted-media" allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/5lwuAuVYlNE" width="600"></iframe></p>

<p>CyHra, the band featuring former Amaranthe singer Jake E. and ex-In Flames guitarist Jesper Strömblad, are currently on the road in North America supporting Sabaton and Kreator. The clip below is the live stream from CyHra's show at The Orpheum Theater in Madison, Wisconsin on February 24th. The setlist was as follows:</p>

<p>"Dead to Me"<br />
"Letter to Myself"<br />
"Here to Save You"<br />
"Heartrage"<br />
"Closure"<br />
"Karma"</p>

<p><iframe allowfullscreen="true" allowtransparency="true" frameborder="0" height="315" scrolling="no" src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FCyHraofficial%2Fvideos%2F541839966182425%2F&amp;show_text=0&amp;width=560" style="border:none;overflow:hidden" width="560"></iframe></p>

<p>CyHra have released a video for "Heartrage", a track from their debut album, released last October via Spinefarm Records. Watch below.</p>

<p><img alt="" src="/medias-static/images/news/2017 II/cyhraalbumaug.jpg" style="width: 512px; height: 512px;" /></p>

<p>Letters To Myself tracklisting:</p>

<p>"Karma"<br />
"Heartrage"<br />
"Here to Save You"<br />
"Muted Life"<br />
"Closure"<br />
"Letter to Myself"<br />
"Dark Clarity"<br />
"Holding Your Breath"<br />
"Rescue Ride"<br />
"Black Wings"<br />
"Inside a Lullaby"<br />
"Dead to Me"</p>

<p>"Heartrage" video:</p>

<p><iframe allow="autoplay; encrypted-media" allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/fOy_yhkzUOQ" width="600"></iframe></p>

<p>"Letter to Myself”:</p>

<p><iframe allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/J8YOOA8eiQQ" width="600"></iframe></p>

<p>"Karma" video:</p>

<p><iframe allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/uvBjQ543l84" width="600"></iframe></p>

<p>Find the band's tour schedule <a href="https://www.facebook.com/CyHraofficial/app/123966167614127/" target="_blank">here</a>.</p>

<p>CyHra are:</p>

<p>Vocals: Jake E (ex-Amaranthe)<br />
Guitar: Jesper Strömblad (ex-In Flames)<br />
Bass: Peter Iwers (ex-In Flames)<br />
Drums: Alex Landenburg (ex-Annihilator)<br />
Guitar: Euge Valovirta (ex-Shining)</p>

      
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

    </div>
    <div id="bw-content-box" class="bw-ads"></div>
    
<div class="disqus-widget">
  <div id="disqus_thread"></div>
</div>

  </div>
  <div class="col-md-4 shared-col">
    
<div class="shared-column">
  <div id="bw-shared-box"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Audio</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="http://bravewords.com/exclusives/audios/player">
        <img src="/medias-static/audios/2018/JudasPriestFirepower.jpg" alt="JUDAS PRIEST - &#34;Firepower&#34; (Epic)" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        JUDAS PRIEST - &#34;Firepower&#34; (Epic)
      </h4>
    </div>
  </div>
</div>

  <div id="bw-clock"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Video</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="/exclusives/videos/shadygrove-scarlet-wood">
        <img src="/medias-static/audios/2018/ShadygroveScarletWood.jpg" alt="SHADYGROVE - &#34;Scarlet Wood&#34;" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        SHADYGROVE - &#34;Scarlet Wood&#34;
      </h4>
    </div>
  </div>
  <div>
    <a class="btn btn-link btn-brand btn-read-more pull-right" href="http://bravewords.com/exclusives/videos">View More</a>
  </div>
</div>

  <div id="bw-shared-small"></div>
  
<div class="panel bw-panel stories-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Latest <span class="text-bold">Reviews</span></h3>
  </div>
  <div class="panel-body">
    <ul class="stories-list">
      <li class="story-media">
        <a class="story-left-image" href="/reviews/judas-priest-firepower">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/5AA2BC74-judas-priest-firepower-thumb.jpg" alt="JUDAS PRIEST - Firepower ">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/judas-priest-firepower">JUDAS PRIEST - Firepower </a>
          </h5>
          <p class="story-published-on">March 9, 2018, 4 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">judas priest</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/candle-the-keeper-s-curse">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/CandleTheKeeper&#39;sCursethumb.jpg" alt="CANDLE - The Keeper&#39;s Curse">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/candle-the-keeper-s-curse">CANDLE - The Keeper&#39;s Curse</a>
          </h5>
          <p class="story-published-on">March 5, 2018, 8 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">candle</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/untervoid-untervoid">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/Untervoidselftitledthumb.jpg" alt="UNTERVOID - Untervoid">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/untervoid-untervoid">UNTERVOID - Untervoid</a>
          </h5>
          <p class="story-published-on">March 4, 2018, 9 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">untervoid</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/greber-cemetery-preston">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/GreberCemeteryPrestonthumb.jpg" alt="GREBER - Cemetery Preston">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/greber-cemetery-preston">GREBER - Cemetery Preston</a>
          </h5>
          <p class="story-published-on">March 4, 2018, 9 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">greber</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/john-corabi-live-94-one-night-in-nashville">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/JohnCorabiLive94thumb.jpg" alt="JOHN CORABI - Live 94: One Night In Nashville">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/john-corabi-live-94-one-night-in-nashville">JOHN CORABI - Live 94: One Night In Nashville</a>
          </h5>
          <p class="story-published-on">March 3, 2018, 10 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">john corabi</span>
            <span class="label label-default label-gray-light">motley crue</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/magick-touch-blades-chains-whips-fire">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/MagickTouchBladesChainesWhips&amp;Firethumb.jpg" alt="MAGICK TOUCH - Blades, Chains, Whips &amp; Fire">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/magick-touch-blades-chains-whips-fire">MAGICK TOUCH - Blades, Chains, Whips &amp; Fire</a>
          </h5>
          <p class="story-published-on">March 3, 2018, 10 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">magick touch</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/oceans-of-slumber-the-banished-heart">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/OceansOfSlumberTheBanishedHeartthumb.jpg" alt="OCEANS OF SLUMBER - The Banished Heart">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/oceans-of-slumber-the-banished-heart">OCEANS OF SLUMBER - The Banished Heart</a>
          </h5>
          <p class="story-published-on">March 2, 2018, 11 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">oceans of slumber</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/blasphemous-squad-ancient-blasphemous-fire">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/BlasphemousSquadAncientBlasphemousFirethumb.jpg" alt="BLASPHEMOUS SQUAD - Ancient Blasphemous Fire">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/blasphemous-squad-ancient-blasphemous-fire">BLASPHEMOUS SQUAD - Ancient Blasphemous Fire</a>
          </h5>
          <p class="story-published-on">March 2, 2018, 11 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">blasphemous squad</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/cruentator-aint-war-hell">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/CruentatorAin&#39;tWarHellthumb.jpg" alt="CRUENTATOR - Ain’t War Hell?">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/cruentator-aint-war-hell">CRUENTATOR - Ain’t War Hell?</a>
          </h5>
          <p class="story-published-on">February 27, 2018, 14 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">cruentator</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/necrophobic-mark-of-the-necrogram">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/NecrophobicMarkOfTheNecrogramthumb.jpg" alt="NECROPHOBIC - Mark Of The Necrogram">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/necrophobic-mark-of-the-necrogram">NECROPHOBIC - Mark Of The Necrogram</a>
          </h5>
          <p class="story-published-on">February 27, 2018, 14 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">necrophobic</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/saxon-thunderbolt">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/SaxonThunderboltthumb.jpg" alt="SAXON - Thunderbolt">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/saxon-thunderbolt">SAXON - Thunderbolt</a>
          </h5>
          <p class="story-published-on">February 24, 2018, 17 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">saxon</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/w-a-s-p-reidolized-the-soundtrack-to-the-crimson-idol">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/WASPReidolizedthumb.jpg" alt="W.A.S.P. - Reidolized (The Soundtrack To The Crimson Idol)">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/w-a-s-p-reidolized-the-soundtrack-to-the-crimson-idol">W.A.S.P. - Reidolized (The Soundtrack To The Crimson Idol)</a>
          </h5>
          <p class="story-published-on">February 24, 2018, 17 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">w.a.s.p.</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/vojd-the-outer-ocean">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/VOJDTheOuterOceanthumb.jpg" alt="VOJD - The Outer Ocean">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/vojd-the-outer-ocean">VOJD - The Outer Ocean</a>
          </h5>
          <p class="story-published-on">February 22, 2018, 19 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">vojd</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/nova-soli-contro-il-mondo">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/NovaSoliControIlMondothumb.jpg" alt="NOVA - Soli Contro il Mondo">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/nova-soli-contro-il-mondo">NOVA - Soli Contro il Mondo</a>
          </h5>
          <p class="story-published-on">February 21, 2018, 20 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">nova</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/dekonstruktor-no-way-back">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/DekonstruktorNoWayBackthumb.jpg" alt="DEKONSTRUKTOR - No Way Back">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/dekonstruktor-no-way-back">DEKONSTRUKTOR - No Way Back</a>
          </h5>
          <p class="story-published-on">February 21, 2018, 20 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">dekonstruktor</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/sacred-leather-ultimate-force">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/SacredLeatherUltimateForcethumb.jpg" alt="SACRED LEATHER - Ultimate Force">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/sacred-leather-ultimate-force">SACRED LEATHER - Ultimate Force</a>
          </h5>
          <p class="story-published-on">February 19, 2018, 22 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">sacred leather</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/scott-ian-access-all-areas">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/ScottIanAccessAllAreasthumb.png" alt="SCOTT IAN - Access All Areas">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/scott-ian-access-all-areas">SCOTT IAN - Access All Areas</a>
          </h5>
          <p class="story-published-on">February 17, 2018, 24 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metla</span>
            <span class="label label-default label-gray-light">scott ian</span>
            <span class="label label-default label-gray-light">anthrax</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/grave-spirit-the-beast-unburdened-by-flesh">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/GraveSpiritTheBeastUnburdenedByFleshthumb.jpg" alt="GRAVE SPIRIT - The Beast Unburdened By Flesh">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/grave-spirit-the-beast-unburdened-by-flesh">GRAVE SPIRIT - The Beast Unburdened By Flesh</a>
          </h5>
          <p class="story-published-on">February 17, 2018, 24 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">grave spirit</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/michael-schenker-fest-resurrection">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/MSFResurrectionthumb.jpg" alt="MICHAEL SCHENKER FEST - Resurrection">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/michael-schenker-fest-resurrection">MICHAEL SCHENKER FEST - Resurrection</a>
          </h5>
          <p class="story-published-on">February 16, 2018, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">riff notes</span>
            <span class="label label-default label-gray-light">michael schenker fest</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/machine-head-catharsis">
          <img class="img-responsive" src="/medias-static/images/reviews/2018/MachineHeadCatharsisthumb.jpg" alt="MACHINE HEAD - Catharsis">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/machine-head-catharsis">MACHINE HEAD - Catharsis</a>
          </h5>
          <p class="story-published-on">February 16, 2018, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">machine head</span>
          </p>
        </div>
      </li>
      <li class="story-read-more">
        <a class="btn btn-link btn-brand btn-read-more" href="http://bravewords.com/reviews">Read More</a>
      </li>
    </ul>
  </div>
</div>

</div>

  </div>
</div>


        <br clear="all">
        <div id="rcjsload_3bd255"></div>
        <script type="text/javascript">
          (function() {
            var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
            var rcel = document.createElement("script");
            rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
            rcel.type = 'text/javascript';
            rcel.src = "http://trends.revcontent.com/serve.js.php?w=44674&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
            rcel.async = true;
            var rcds = document.getElementById("rcjsload_3bd255"); rcds.appendChild(rcel);
          })();
        </script>

      </div>
    </div>
  </div>
</section>

<section id="footer" data-region="footer">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 footer">
        
  bravewords.com • <a href="/terms-and-conditions">Terms & Conditions</a>

      </div>
    </div>
  </div>
</section>

<div id="modal" class="modal" data-region="modal"></div>


    <script src="/assets-static/vendors.121dfc00550765bd7777.js"></script>
    <script src="/assets-static/app.121dfc00550765bd7777.js"></script>
    
  </body>
</html>




