<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>DAVID ELLEFSON Releases “Sleeping Giants” Video Featuring RUN DMC’s DARRYL “DMC” MCDANIELS - Bravewords.com</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="news, heavy metal, david ellefson, megadeth, run dmc">
    <meta name="description" content="Megadeth bassist David Ellefson has released a video for “Sleeping Giants”, the title track from his debut solo release Sleeping Giants, in stores now via Combat Records. Sleeping Giants is a companion release to his new memoir More Life With Deth, in stores now via Jawbone Press.
The track, features...">
    <meta name="author" content="bravewords.com">
    <meta name="verify-v1" content="UG2Z0A6uZRfu/o3aZh9WaxJSVUDm4RZbqJrFe/F7Mis=" />
    <meta name="alexaVerifyID" content="S1M8-AaHKAG76rKFC1bczMy8KvM" />
    <meta name="bitly-verification" content="444d87609be9" />
    
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="DAVID ELLEFSON Releases “Sleeping Giants” Video Featuring RUN DMC’s DARRYL “DMC” MCDANIELS" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://bravewords.com/news/david-ellefson-releases-sleeping-giants-video-featuring-run-dmcs-darryl-dmc-mcdaniels" />
<meta property="og:image" content="http://bravewords.com/medias-static/images/news/2019/5D60576A-david-ellefson-releases-sleeping-giants-video-featuring-run-dmcs-darryl-dmc-mcdaniels-image.jpg" />
<meta property="og:description" content="Megadeth bassist David Ellefson has released a video for “Sleeping Giants”, the title track from his debut solo release Sleeping Giants, in stores now via Combat Records. Sleeping Giants is a companion release to his new memoir More Life With Deth, in stores now via Jawbone Press.
The track, features..." />
<meta property="og:site_name" content="bravewords.com" />
<meta property="article:publisher" content="https://www.facebook.com/bravewords" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="heavy metal" />
<meta property="article:tag" content="david ellefson" />
<meta property="article:tag" content="megadeth" />
<meta property="article:tag" content="run dmc" />
<meta property="fb:app_id" content="684233228278895" />

    
<meta name="twitter:card" content="summary">
<meta property="twitter:url" content="http://bravewords.com/news/david-ellefson-releases-sleeping-giants-video-featuring-run-dmcs-darryl-dmc-mcdaniels" />
<meta name="twitter:site" content="@BraveWords666">
<meta name="twitter:domain" content="bravewords.com">
<meta name="twitter:title" content="DAVID ELLEFSON Releases “Sleeping Giants” Video Featuring RUN DMC’s DARRYL “DMC” MCDANIELS">
<meta name="twitter:description" content="Megadeth bassist David Ellefson has released a video for “Sleeping Giants”, the title track from his debut solo release Sleeping Giants, in stores now via Combat Records. Sleeping Giants is a companion release to his new memoir More Life With Deth, in stores now via Jawbone Press.
The track, features...">
<meta name="twitter:creator" content="@BraveWords666">
<meta name="twitter:image" content="http://bravewords.com/medias-static/images/news/2019/5D60576A-david-ellefson-releases-sleeping-giants-video-featuring-run-dmcs-darryl-dmc-mcdaniels-image.jpg">

    <!-- Bootstrap -->
    <link href="/assets-static/vendors.0bff35fbc4d494b9cd40.css" rel="stylesheet">
    <link href="/assets-static/app.0bff35fbc4d494b9cd40.css" rel="stylesheet">
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 10]>
      <script src="//cdn.jsdelivr.net/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="//cdn.jsdelivr.net/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <link rel="shortcut icon" href="/app-static/favicon.png">
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS News Channel" href="http://bravewords.com/rss/news.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Reviews Channel" href="http://bravewords.com/rss/reviews.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Features Channel" href="http://bravewords.com/rss/features.xml"/>
    

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f148a0f143921a1" async="async"></script>
<script src="https://Q1MediaHydraPlatform.com/ads/video/controller.php?qid=588f5a2956c2586c325b9421&qz=1" async></script>
<script async id="aniviewJS892590094" src="https://play.aniview.com/56f146aa181f467d0a8b45c1/5b7d522c28a0616498072cbb/bravewords_Floater.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/bravewords/loader.js');
</script>
<script src="https://cdn.reignn.com/Clients/Publishers/70318/Sites/Bravewords.com/Bravewords.com.js"></script>
<script type="text/javascript">
var $BWCategory = 'news';
var $BWTags = ['news', 'heavy metal', 'david ellefson', 'megadeth', 'run dmc'];
var $BWContentType = 'article';
var $BWTargetDomain = 'www.revolvermag.com';
</script>
<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/29ac4385-3ca7-4db1-853a-ce2ff340f9f9.js');/*]]>*/</script>

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-342765-2', 'auto');
      ga('send', 'pageview');
    </script>
    <script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//connect.facebook.net/en_US/all.js"></script>
  </head>
  <body id="root">
    <div id="pace-loader"></div>

    



<div id="bw-takeover" class="takeover"></div>

<section id="header" data-region="header">
  <div class="container container-defaults header">
    <div class="row">
      <div id="top-logo" class="col-sm-6 col-sm-offset-3">
        <div class="top-logo">
          <a href="http://bravewords.com/home">
            <img src="/assets-static/img/bravewords-350.png">
          </a>
        </div>
      </div>
      <div id="top-nav" class="col-sm-3">
        <ul class="top-nav">
          <li>
            <a href="https://www.facebook.com/bravewords">
              <i class="fa fa-facebook"></i>
            </a>
          </li>
          <li>
            <a href="https://twitter.com/bravewords666">
              <i class="fa fa-twitter"></i>
            </a>
          </li>
          <li>
            <a href="#">
              <i class="fa fa-youtube"></i>
            </a>
          </li>
        </ul>
      </div>
    </div>
    <div class="row">
      <div class="leaderboard">
        <div id="bw-leaderboard"></div>
      </div>
    </div>
  </div>
</section>

<section id="main-nav" class="afflix" data-spy="afflix">
  <div class="container container-defaults">
    <nav class="navbar navbar-inverse" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
        </button>
        <div class="navbar-brand">
          <div class="nav-logo">
            <img src="/assets-static/img/bw.png">
          </div>
        </div>
      </div>

      <!-- Collect the nav links, forms, and other content for toggling -->
      <div class="collapse navbar-collapse" id="navbar-collapse">
        <ul class="nav navbar-nav navbar-main">
          <li class=""><a href="/home">Home</a></li>
          <li class="dropdown active">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">News <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/news">Latest News</a></li>
              <li><a href="/news?t=heavy+metal">Heavy Metal</a></li>
              <li><a href="/news?t=black+death">Black Death</a></li>
              <li><a href="/news?t=hard+rock">Hard Rock</a></li>
              <li><a href="/news?t=classic+rock">Classic Rock</a></li>
              <li><a href="/news?t=riff+notes">Riff Notes</a></li>
              <li><a href="/news?t=rarities">Rarities</a></li>
            </ul>
          </li>
          <li class=""><a href="/reviews">Reviews</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Medias <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/galleries">Galleries</a></li>
              <li><a href="/videos">Videos</a></li>
              <li><a href="/exclusives/videos">Featured Videos</a></li>
              <li><a href="/exclusives/audios/player">Featured Audios</a></li>
            </ul>
          </li>
          <li class=""><a href="/metal-market">Market</a></li>
          <li class=""><a href="http://bb.bravewords.com">Board</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">About <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/about/contact">Contact</a></li>
              <li><a href="/about/who-we-are">Who We Are</a></li>
              <li><a href="/about/how-to-advertise">How To Advertise</a></li>
            </ul>
          </li>
        </ul>
        <ul class="nav navbar-nav navbar-right navbar-search">
          <li class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
              <i class="fa fa-search search-icon"></i>
            </a>
            <div class="dropdown-menu dropdown-search">
              <form
                class="navbar-form navbar-right"
                role="search"
                action="http://bravewords.com/search"
                >
                <div>
                  <input
                    type="text"
                    class="form-control input-md global-search"
                    name="q"
                    placeholder="SEARCH"
                    >
                </div>
              </form>
            </div>
          </li>
        </ul>
      </div>
    </nav>
  </div>
</section>

<section id="content" data-region="body">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 content">
        

<div class="row">
  <div class="col-md-8 page-content">
    <div class="clearfix">
      <h2 class="page-title">DAVID ELLEFSON Releases “Sleeping Giants” Video Featuring RUN DMC’s DARRYL “DMC” MCDANIELS</h2>
      <p class="page-publish-on">August 23, 2019, an hour ago</p>
      <p class="page-tags">
        <span class="label label-default label-gray-light">news</span>
        <span class="label label-default label-gray-light">heavy metal</span>
        <span class="label label-default label-gray-light">david ellefson</span>
        <span class="label label-default label-gray-light">megadeth</span>
        <span class="label label-default label-gray-light">run dmc</span>
      </p>
      <div class="addthis_sharing_toolbox pull-right"></div>
    </div>
    <div class="page-body">
      <img class="img-responsive page-image" src="/medias-static/images/news/2019/5D60576A-david-ellefson-releases-sleeping-giants-video-featuring-run-dmcs-darryl-dmc-mcdaniels-image.jpg" alt="DAVID ELLEFSON Releases “Sleeping Giants” Video Featuring RUN DMC’s DARRYL “DMC” MCDANIELS">
      <p>Megadeth bassist David Ellefson has released a video for “Sleeping Giants”, the title track from his debut solo release Sleeping Giants, in stores now via Combat Records. Sleeping Giants is a companion release to his new memoir More Life With Deth, in stores now via Jawbone Press.</p>

<p>The track, features lead vocals by Ellefson’s partner, and More Life With Deth co-author, Thom Hazaert, and legendary hip-hop MC Daryl “DMC” McDaniels, plus guest appearances by Steve Conley (Flotsam and Jetsam), Ethan Brosh, Bumblefoot, and Ilias Papadakis (Memorain).</p>

<p><img alt="" src="/medias-static/images/news/2019/sleepinggiantscover.jpg" style="width: 600px; height: 599px;" /></p>

<p>Says Hazaert, “David had all these great instrumental songs laying around, and Sleeping Giants was one of them. He suggested I write and record some vocals parts for them, so I called up DMC and asked if he’d want to collaborate with us on a track, and we got to work. I’ve always loved off the wall metal/hip-hop collaborations, Judgement Night etc. And I think ‘Giants’ definitely draws from that. The song and video both ended up with a really cool aggressive, old-school New York hardcore/hip-hop. feel. It my book, it doesn’t get any more legendary than Run DMC. And this was definitely one for the history books.”</p>

<p>Ellefson adds, “It was truly an honor to collaborate with DMC, and I think the track came out great. When Thom said DMC wanted to do a collaboration with us, I instantly thought of ‘Sleeping Giants’. And when he came out to Revolution in Amityville to perform with us, and shoot the video, it was an awesome energy. I think everyone there got a show they won’t ever forget.”</p>

<p>Released in North America on July 19th, and debuting on 12 Billboard sales charts, Sleeping Giants will be released in Europe in November, as Ellefson and Hazaert cross the pond for a string of European shows and signings on their Sleeping Giants/More Life With Deth tour.</p>

<p>Shot on location in Amityville, NY, Phoenix, AZ, and The Salton Sea in California, the video, directed by Melody Myers and Thom Hazaert, and filmed and edited by Melody Myers/Designed by Melody (Altitudes and Attitude, Escape The Fate), can be viewed below:</p>

<p><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/nn8QdhXAVkE" width="600"></iframe></p>

      <br clear="all">
      
<br clear="all">
<div id="zergnet-widget-70729"></div>
<script language="javascript" type="text/javascript">
  (function() {
    var zergnet = document.createElement('script');
    zergnet.type = 'text/javascript'; zergnet.async = true;
    zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=70729';
    var znscr = document.getElementsByTagName('script')[0];
    znscr.parentNode.insertBefore(zergnet, znscr);
  })();
</script>

      
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

    </div>
    <div id="bw-content-box" class="bw-ads"></div>
    
<div class="disqus-widget">
  <div id="disqus_thread"></div>
</div>

  </div>
  <div class="col-md-4 shared-col">
    
<div class="shared-column">
  <div id="bw-shared-box"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Audio</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="http://bravewords.com/exclusives/audios/player">
        <img src="/medias-static/audios/2019/Aftermath19.jpg" alt="AFTERMATH - &#34;Diethanasia&#34; (The Label Group)" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        AFTERMATH - &#34;Diethanasia&#34; (The Label Group)
      </h4>
    </div>
  </div>
</div>

  <div id="bw-shared-medium"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Video</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="/exclusives/videos/aftermath-premieres-temptation-overthrown">
        <img src="/medias-static/audios/2019/AftermathThereIsSomethingWrong.jpg" alt="AFTERMATH Premieres &#34;Temptation Overthrown&#34;" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        AFTERMATH Premieres &#34;Temptation Overthrown&#34;
      </h4>
    </div>
  </div>
  <div>
    <a class="btn btn-link btn-brand btn-read-more pull-right" href="http://bravewords.com/exclusives/videos">View More</a>
  </div>
</div>

  <div id="bw-shared-small"></div>
  
<div class="panel bw-panel stories-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Latest <span class="text-bold">Reviews</span></h3>
  </div>
  <div class="panel-body">
    <ul class="stories-list">
      <li class="story-media">
        <a class="story-left-image" href="/reviews/northtale-welcome-to-paradise">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/NorthtaleWelcomeToParadisethumb.jpg" alt="NORTHTALE - Welcome To Paradise">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/northtale-welcome-to-paradise">NORTHTALE - Welcome To Paradise</a>
          </h5>
          <p class="story-published-on">August 21, 2019, 2 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">northtale</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/destruction-born-to-perish">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/5D4EDAFF-destruction-born-to-perish-thumb.jpg" alt="DESTRUCTION – Born To Perish">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/destruction-born-to-perish">DESTRUCTION – Born To Perish</a>
          </h5>
          <p class="story-published-on">August 10, 2019, 13 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">destruction</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/torche-admission">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/5D4ED9EA-torche-admission-thumb.jpg" alt="TORCHE – Admission">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/torche-admission">TORCHE – Admission</a>
          </h5>
          <p class="story-published-on">August 9, 2019, 14 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">torche</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/darkride-weight-of-the-world">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/DarkrideWeightOfTheWorldthumb.jpg" alt="DARKRIDE – Weight Of The World">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/darkride-weight-of-the-world">DARKRIDE – Weight Of The World</a>
          </h5>
          <p class="story-published-on">August 8, 2019, 15 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">darkride</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/wear-your-wounds-rust-on-the-gates-of-heaven">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/WearYourWoundsRustOnTheGatesOfHeaventhumb.jpg" alt="WEAR YOUR WOUNDS - Rust On The Gates Of Heaven">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/wear-your-wounds-rust-on-the-gates-of-heaven">WEAR YOUR WOUNDS - Rust On The Gates Of Heaven</a>
          </h5>
          <p class="story-published-on">August 3, 2019, 20 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">wear your wounds</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/pathetic-rat-king">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/PatheticRatKingtthumb.jpg" alt="PATHETIC - Rat King">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/pathetic-rat-king">PATHETIC - Rat King</a>
          </h5>
          <p class="story-published-on">July 31, 2019, 22 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">pathetic</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/vulture-ghastly-waves-battered-graves">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/VultureGhastlyWaves&amp;BatteredGravesthumb.jpg" alt="VULTURE - Ghastly Waves &amp; Battered Graves">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/vulture-ghastly-waves-battered-graves">VULTURE - Ghastly Waves &amp; Battered Graves</a>
          </h5>
          <p class="story-published-on">July 31, 2019, 23 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">vulture</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/loudness-live-in-tokyo">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/LoudnessLiveInTokyothumb.jpg" alt="LOUDNESS - Live In Tokyo">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/loudness-live-in-tokyo">LOUDNESS - Live In Tokyo</a>
          </h5>
          <p class="story-published-on">July 29, 2019, 24 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">loudness</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/tomb-mold-planetary-clairvoyance">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/TombMoldPlanetaryClairvoyancethumb.jpg" alt="TOMB MOLD - Planetary Clairvoyance">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/tomb-mold-planetary-clairvoyance">TOMB MOLD - Planetary Clairvoyance</a>
          </h5>
          <p class="story-published-on">July 29, 2019, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">tomb mold</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/martin-popoff-aces-high-the-top-250-heavy-metal-songs-of-the-80s">
          <img class="img-responsive" src="/medias-static/images/reviews/2019/MartinPopoffAcesHighthumb.jpg" alt="MARTIN POPOFF – Aces High: The Top 250 Heavy Metal Songs Of The ‘80s">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/martin-popoff-aces-high-the-top-250-heavy-metal-songs-of-the-80s">MARTIN POPOFF – Aces High: The Top 250 Heavy Metal Songs Of The ‘80s</a>
          </h5>
          <p class="story-published-on">July 27, 2019, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">martin popoff</span>
          </p>
        </div>
      </li>
      <li class="story-read-more">
        <a class="btn btn-link btn-brand btn-read-more" href="http://bravewords.com/reviews">Read More</a>
      </li>
    </ul>
  </div>
</div>

  

<br clear="all">
<div>
<script
  type="text/javascript"
  language="javascript"
  src="https://live.sekindo.com/live/liveView.php?s=99959&cbuster=1566599005&pubUrl=http%3A%2F%2Fbravewords.com%2Fnews%2Fdavid-ellefson-releases-sleeping-giants-video-featuring-run-dmcs-darryl-dmc-mcdaniels&x=300&y=250&vp_content=plembed146erlohukmv&vp_template=5888&subId=[SUBID_ENCODED]">
</script>
</div>

  
<br clear="all">
<div id="insticator-container">
  <div id="div-insticator-ad-1" adonis-marker></div>
  <div id="insticator-embed" embed-id="c9e2d7ce-e545-4ad6-9ace-ef50b2853f4d"></div>
  <div id="div-insticator-ad-2" adonis-marker></div>
  <script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "c9e2d7ce-e545-4ad6-9ace-ef50b2853f4d"});/*]]>*/</script>
</div>

  <br clear="all">
</div>

  </div>
</div>

        <br clear="all">
        <div id="zergnet-widget-70730"></div>
        <script language="javascript" type="text/javascript">
          (function() {
            var zergnet = document.createElement('script');
            zergnet.type = 'text/javascript'; zergnet.async = true;
            zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=70730';
            var znscr = document.getElementsByTagName('script')[0];
            znscr.parentNode.insertBefore(zergnet, znscr);
          })();
        </script>
      </div>
    </div>
  </div>
</section>

<section id="footer" data-region="footer">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 footer">
        
  bravewords.com • <a href="/terms-and-conditions">Terms & Conditions</a>

      </div>
    </div>
  </div>
</section>

<div id="modal" class="modal" data-region="modal"></div>


    <script src="/assets-static/vendors.0bff35fbc4d494b9cd40.js"></script>
    <script src="/assets-static/app.0bff35fbc4d494b9cd40.js"></script>
    
    <!--- UNDERDOGMEDIA EDGE_BraveWords.com JavaScript ADCODE START--->
    <script data-cfasync="false" language="javascript" async src="//udmserve.net/udm/img.fetch?sid=13687;tid=1;dt=6;"></script>
    <!--- UNDERDOGMEDIA EDGE_BraveWords.com JavaScript ADCODE END--->
  </body>
</html>




