<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>MEGADETH Bassist DAVID ELLEFSON Talks Dystopia Album - &#34;It Took Us A Lot Of Years To Turn Our Ship Around And Try To Get It Back On Course&#34; - Bravewords.com</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="news, megadeth, heavy metal">
    <meta name="description" content="Megadeth bassist David Ellefson recently guested on the 1007 WZLX SixX Strings radio show and discussed the band&#39;s latest album, Dystopia, as well as their Grammy win for the record. Check out the interview below.

In a new interview with Billboard, Megadeth leader Dave Mustaine talks about the band’s first...">
    <meta name="author" content="bravewords.com">
    <meta name="verify-v1" content="UG2Z0A6uZRfu/o3aZh9WaxJSVUDm4RZbqJrFe/F7Mis=" />
    <meta name="alexaVerifyID" content="S1M8-AaHKAG76rKFC1bczMy8KvM" />
    <meta name="bitly-verification" content="444d87609be9" />
    
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="MEGADETH Bassist DAVID ELLEFSON Talks Dystopia Album - &#34;It Took Us A Lot Of Years To Turn Our Ship Around And Try To Get It Back On Course&#34;" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://bravewords.com/news/megadeth-bassist-david-ellefson-talks-dystopia-album-it-took-us-a-lot-of-years-to-turn-our-ship-around-and-try-to-get-it-back-on-course" />
<meta property="og:image" content="http://bravewords.com/medias-static/images/news/2017/58AD57D7-megadeth-bassist-david-ellefson-talks-dystopia-album-it-took-us-a-lot-of-years-to-turn-our-ship-around-and-try-to-get-it-back-on-course-image.jpg" />
<meta property="og:description" content="Megadeth bassist David Ellefson recently guested on the 1007 WZLX SixX Strings radio show and discussed the band&#39;s latest album, Dystopia, as well as their Grammy win for the record. Check out the interview below.

In a new interview with Billboard, Megadeth leader Dave Mustaine talks about the band’s first..." />
<meta property="og:site_name" content="bravewords.com" />
<meta property="article:publisher" content="https://www.facebook.com/bravewords" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="megadeth" />
<meta property="article:tag" content="heavy metal" />
<meta property="fb:app_id" content="684233228278895" />

    
<meta name="twitter:card" content="summary">
<meta property="twitter:url" content="http://bravewords.com/news/megadeth-bassist-david-ellefson-talks-dystopia-album-it-took-us-a-lot-of-years-to-turn-our-ship-around-and-try-to-get-it-back-on-course" />
<meta name="twitter:site" content="@BraveWords666">
<meta name="twitter:domain" content="bravewords.com">
<meta name="twitter:title" content="MEGADETH Bassist DAVID ELLEFSON Talks Dystopia Album - &#34;It Took Us A Lot Of Years To Turn Our Ship Around And Try To Get It Back On Course&#34;">
<meta name="twitter:description" content="Megadeth bassist David Ellefson recently guested on the 1007 WZLX SixX Strings radio show and discussed the band&#39;s latest album, Dystopia, as well as their Grammy win for the record. Check out the interview below.

In a new interview with Billboard, Megadeth leader Dave Mustaine talks about the band’s first...">
<meta name="twitter:creator" content="@BraveWords666">
<meta name="twitter:image" content="http://bravewords.com/medias-static/images/news/2017/58AD57D7-megadeth-bassist-david-ellefson-talks-dystopia-album-it-took-us-a-lot-of-years-to-turn-our-ship-around-and-try-to-get-it-back-on-course-image.jpg">

    <!-- Bootstrap -->
    <link href="/assets-static/vendors.121dfc00550765bd7777.css" rel="stylesheet">
    <link href="/assets-static/app.121dfc00550765bd7777.css" rel="stylesheet">
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 10]>
      <script src="//cdn.jsdelivr.net/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="//cdn.jsdelivr.net/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <link rel="shortcut icon" href="/app-static/favicon.png">
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS News Channel" href="http://bravewords.com/rss/news.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Reviews Channel" href="http://bravewords.com/rss/reviews.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Features Channel" href="http://bravewords.com/rss/features.xml"/>
    

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f148a0f143921a1" async="async"></script>
<script src="https://Q1MediaHydraPlatform.com/ads/video/controller.php?qid=588f5a2956c2586c325b9421&qz=1" async></script>

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-342765-2', 'auto');
      ga('send', 'pageview');
    </script>
    <script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//connect.facebook.net/en_US/all.js"></script>
    <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({article:'auto'});
      !function (e, f, u) {
        e.async = 1;
        e.src = u;
        f.parentNode.insertBefore(e, f);
      }(document.createElement('script'),
      document.getElementsByTagName('script')[0],
      '//cdn.taboola.com/libtrc/bravewords/loader.js');
    </script>

  </head>
  <body id="root">
    <div id="pace-loader"></div>
    



<div id="bw-takeover" class="takeover"></div>

<section id="header" data-region="header">
  <div class="container container-defaults header">
    <div class="row">
      <div id="top-logo" class="col-sm-6 col-sm-offset-3">
        <div class="top-logo">
          <a href="http://bravewords.com/home">
            <img src="/assets-static/img/bravewords-350.png">
          </a>
        </div>
      </div>
      <div id="top-nav" class="col-sm-3">
        <ul class="top-nav">
          <li>
            <a href="https://www.facebook.com/bravewords">
              <i class="fa fa-facebook"></i>
            </a>
          </li>
          <li>
            <a href="https://twitter.com/bravewords666">
              <i class="fa fa-twitter"></i>
            </a>
          </li>
          <li>
            <a href="#">
              <i class="fa fa-youtube"></i>
            </a>
          </li>
        </ul>
      </div>
    </div>
    <div class="row">
      <div class="leaderboard">
        <div id="bw-leaderboard"></div>
      </div>
    </div>
  </div>
</section>

<section id="main-nav" class="afflix" data-spy="afflix">
  <div class="container container-defaults">
    <nav class="navbar navbar-inverse" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
        </button>
        <div class="navbar-brand">
          <div class="nav-logo">
            <img src="/assets-static/img/bw.png">
          </div>
        </div>
      </div>

      <!-- Collect the nav links, forms, and other content for toggling -->
      <div class="collapse navbar-collapse" id="navbar-collapse">
        <ul class="nav navbar-nav navbar-main">
          <li class=""><a href="/home">Home</a></li>
          <li class="dropdown active">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">News <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/news">Latest News</a></li>
              <li><a href="/news?t=heavy+metal">Heavy Metal</a></li>
              <li><a href="/news?t=black+death">Black Death</a></li>
              <li><a href="/news?t=hard+rock">Hard Rock</a></li>
              <li><a href="/news?t=classic+rock">Classic Rock</a></li>
              <li><a href="/news?t=riff+notes">Riff Notes</a></li>
              <li><a href="/news?t=rarities">Rarities</a></li>
            </ul>
          </li>
          <li class=""><a href="/reviews">Reviews</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Medias <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/galleries">Galleries</a></li>
              <li><a href="/videos">Videos</a></li>
              <li><a href="/exclusives/videos">Featured Videos</a></li>
              <li><a href="/exclusives/audios/player">Featured Audios</a></li>
            </ul>
          </li>
          <li class=""><a href="/metal-market">Market</a></li>
          <li class=""><a href="http://bb.bravewords.com">Board</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">About <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/about/contact">Contact</a></li>
              <li><a href="/about/who-we-are">Who We Are</a></li>
              <li><a href="/about/how-to-advertise">How To Advertise</a></li>
            </ul>
          </li>
        </ul>
        <ul class="nav navbar-nav navbar-right navbar-search">
          <li class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
              <i class="fa fa-search search-icon"></i>
            </a>
            <div class="dropdown-menu dropdown-search">
              <form
                class="navbar-form navbar-right"
                role="search"
                action="http://bravewords.com/search"
                >
                <div>
                  <input
                    type="text"
                    class="form-control input-md global-search"
                    name="q"
                    placeholder="SEARCH"
                    >
                </div>
              </form>
            </div>
          </li>
        </ul>
      </div>
    </nav>
  </div>
</section>

<section id="content" data-region="body">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 content">
        

<div class="row">
  <div class="col-md-8 page-content">
    <div class="clearfix">
      <h2 class="page-title">MEGADETH Bassist DAVID ELLEFSON Talks Dystopia Album - &#34;It Took Us A Lot Of Years To Turn Our Ship Around And Try To Get It Back On Course&#34;</h2>
      <p class="page-publish-on">February 22, 2017, an hour ago</p>
      <p class="page-tags">
        <span class="label label-default label-gray-light">news</span>
        <span class="label label-default label-gray-light">megadeth</span>
        <span class="label label-default label-gray-light">heavy metal</span>
      </p>
      <div class="addthis_sharing_toolbox pull-right"></div>
    </div>
    <div class="page-body">
      <img class="img-responsive page-image" src="/medias-static/images/news/2017/58AD57D7-megadeth-bassist-david-ellefson-talks-dystopia-album-it-took-us-a-lot-of-years-to-turn-our-ship-around-and-try-to-get-it-back-on-course-image.jpg" alt="MEGADETH Bassist DAVID ELLEFSON Talks Dystopia Album - &#34;It Took Us A Lot Of Years To Turn Our Ship Around And Try To Get It Back On Course&#34;">
      <p>Megadeth bassist David Ellefson recently guested on the 1007 WZLX SixX Strings radio show and discussed the band's latest album, Dystopia, as well as their Grammy win for the record. Check out the interview below.</p>

<p><iframe frameborder="0" height="400" id="cbsembed" src="http://cbsloc.al/2maAjMF" width="600"></iframe></p>

<p>In a new interview with <a href="http://www.billboard.com/articles/columns/rock/7694277/megadeth-dave-mustaine-interview-grammy-2017-metallica-dystopia" target="_blank">Billboard</a>, Megadeth leader Dave Mustaine talks about the band’s first-ever Grammy win (for the title track from their 2016 album, Dystopia) earning the prize for best metal performance. Megadeth had been nominated nine times before in their 34-year career, so Mustaine finally hit it big on number ten.</p>

<p>About the accolades he says: “Obviously the gratitude of being recognized, but also the disappointment lingering from the years where they’ve given the award to somebody that didn’t belong in that category."</p>

<p>But when the Grammys house band launched into “Master of Puppets” as the band took the stage to receive their honour, it could’ve been an uncomfortable moment given Mustaine’s history with Metallica.</p>

<p>“They could have played any song by anybody, and it wouldn’t have mattered because that was our moment,” he says. “I could see the correlation with [the band] who would think, 'Oh, Megadeth, Metallica, we don’t know any Megadeth, but we do know this one Metallica song, so let’s play this. You think he’ll get mad? I don’t think so, let’s hope not. Hit it, Lefty!' And then we get up there and go, ‘Boy, that was the worst fucking version of ‘Master of Puppets’ I’ve ever heard.' But that kind of stuff, you’ve just won a Grammy and you’re going to worry about some house band doing a cover song in the background?”</p>

<p>Mustaine says Megadeth will follow-up Dystopia sometime next year. “I’m pretty afraid of picking up my guitar during the off season, so I try to keep my distance from it. It starts to call my name when it gets close to new record time, and the past couple weeks, I’ve actually been playing a little bit, so it’s kind of like ‘ok, here we go.'”</p>

<p>Read the entire story at <a href="http://www.billboard.com/articles/columns/rock/7694277/megadeth-dave-mustaine-interview-grammy-2017-metallica-dystopia" target="_blank">Billboard</a>.</p>

<p><iframe allowfullscreen="" frameborder="0" height="400" src="https://www.youtube.com/embed/7gpvXR3ifvo" width="600"></iframe></p>

      
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

    </div>
    <div id="bw-content-box" class="bw-ads"></div>
    
<div class="disqus-widget">
  <div id="disqus_thread"></div>
</div>

  </div>
  <div class="col-md-4 shared-col">
    
<div class="shared-column">
  <div id="bw-shared-box"></div>
  <div id="bw-clock"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Audio</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="http://bravewords.com/exclusives/audios/player">
        <img src="/medias-static/audios/2017/TheWild!WildAtHeart.jpg" alt="THE WILD! - &#34;Ready To Roll&#34; (eOne)" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        THE WILD! - &#34;Ready To Roll&#34; (eOne)
      </h4>
    </div>
  </div>
</div>

  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Video</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="/exclusives/videos/rich-davis-takes-you-to-the-death-star">
        <img src="/medias-static/audios/2017/RichDavisDeathStar.jpg" alt="RICH DAVIS Takes You To The “Death Star”" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        RICH DAVIS Takes You To The “Death Star”
      </h4>
    </div>
  </div>
  <div>
    <a class="btn btn-link btn-brand btn-read-more pull-right" href="http://bravewords.com/exclusives/videos">View More</a>
  </div>
</div>

  <div id="bw-shared-small"></div>
  
<div class="panel bw-panel stories-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Latest <span class="text-bold">Reviews</span></h3>
  </div>
  <div class="panel-body">
    <ul class="stories-list">
      <li class="story-media">
        <a class="story-left-image" href="/reviews/accept-restless-and-live">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/AcceptRestlessAndLivethumb.jpg" alt="ACCEPT - Restless And Live">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/accept-restless-and-live">ACCEPT - Restless And Live</a>
          </h5>
          <p class="story-published-on">February 21, 2017, 15 hours ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">accept</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/fall-of-carthage-the-longed-for-reckoning">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/FallOfCarthageTheLongedForReckoningthumb.jpg" alt="FALL OF CARTHAGE - The Longed-For Reckoning">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/fall-of-carthage-the-longed-for-reckoning">FALL OF CARTHAGE - The Longed-For Reckoning</a>
          </h5>
          <p class="story-published-on">February 17, 2017, 4 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">fall of carthage</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/overkill-the-grinding-wheel">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/OverkillTheGrindingWheelthumb.jpg" alt="OVERKILL - The Grinding Wheel">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/overkill-the-grinding-wheel">OVERKILL - The Grinding Wheel</a>
          </h5>
          <p class="story-published-on">February 15, 2017, 6 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">overkill</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/firewind-immortals">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/FirewindImmortalsthumb.jpg" alt="FIREWIND - Immortals">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/firewind-immortals">FIREWIND - Immortals</a>
          </h5>
          <p class="story-published-on">February 12, 2017, 9 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">firewind</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/jack-russell-s-great-white-he-saw-it-comin">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/JackRussell&#39;sGreatWhiteHeSawItComin&#39;thumb.jpg" alt="JACK RUSSELL&#39;S GREAT WHITE - He Saw It Comin&#39;">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/jack-russell-s-great-white-he-saw-it-comin">JACK RUSSELL&#39;S GREAT WHITE - He Saw It Comin&#39;</a>
          </h5>
          <p class="story-published-on">February 10, 2017, 11 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">jack russell&#39;s great white</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/hour-of-penance-cast-the-first-stone">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/HourOfPenanceCastTheFirstStonethumb.jpg" alt="HOUR OF PENANCE - Cast The First Stone">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/hour-of-penance-cast-the-first-stone">HOUR OF PENANCE - Cast The First Stone</a>
          </h5>
          <p class="story-published-on">February 8, 2017, 13 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">hour of penance</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/hell-fire-metal-masses">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/HellFireMetalMassesthumb.jpg" alt="HELL FIRE - Metal Masses">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/hell-fire-metal-masses">HELL FIRE - Metal Masses</a>
          </h5>
          <p class="story-published-on">February 6, 2017, 15 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">hell fire</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/stephen-pearcy-smash">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/StephenPearcySmashthumb.jpg" alt="STEPHEN PEARCY - Smash">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/stephen-pearcy-smash">STEPHEN PEARCY - Smash</a>
          </h5>
          <p class="story-published-on">February 4, 2017, 17 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">stephen pearcy</span>
            <span class="label label-default label-gray-light">ratt</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/source-source">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/Sourceselftitledthumb.jpg" alt="SOURCE - Source">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/source-source">SOURCE - Source</a>
          </h5>
          <p class="story-published-on">February 2, 2017, 19 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">source</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/john-garcia-the-coyote-who-spoke-in-tongues">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/JohnGarciaTheCoyoteWhoSpokeInTonguesthumb.jpg" alt="JOHN GARCIA - The Coyote Who Spoke In Tongues">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/john-garcia-the-coyote-who-spoke-in-tongues">JOHN GARCIA - The Coyote Who Spoke In Tongues</a>
          </h5>
          <p class="story-published-on">January 31, 2017, 21 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">john garcia</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/judas-priest-turbo-30th-anniversary-edition">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/JudasPriestTurbo30thumb.jpg" alt="JUDAS PRIEST - Turbo (30th Anniversary Edition)">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/judas-priest-turbo-30th-anniversary-edition">JUDAS PRIEST - Turbo (30th Anniversary Edition)</a>
          </h5>
          <p class="story-published-on">January 30, 2017, 22 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">rarities</span>
            <span class="label label-default label-gray-light">judas priest</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/kreator-gods-of-violence">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/KreatorGodsOfViolencethumb.jpg" alt="KREATOR - Gods Of Violence">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/kreator-gods-of-violence">KREATOR - Gods Of Violence</a>
          </h5>
          <p class="story-published-on">January 28, 2017, 24 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">kreator</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/nightwish-vehicle-of-spirit">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/NightwishVehicleOfSpiritthumb.jpg" alt="NIGHTWISH - Vehicle Of Spirit ">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/nightwish-vehicle-of-spirit">NIGHTWISH - Vehicle Of Spirit </a>
          </h5>
          <p class="story-published-on">January 27, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">nightwish</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/metal-witch-tales-from-the-underground">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/MetalWitchTalesFromTheUndergroundthumb.jpg" alt="METAL WITCH - Tales From The Underground">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/metal-witch-tales-from-the-underground">METAL WITCH - Tales From The Underground</a>
          </h5>
          <p class="story-published-on">January 26, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">metal witch</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/soul-dealer-holy-in-your-head">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/SoulDealerTheHolyInYourHeadthumb.jpg" alt="SOUL DEALER - Holy In Your Head">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/soul-dealer-holy-in-your-head">SOUL DEALER - Holy In Your Head</a>
          </h5>
          <p class="story-published-on">January 25, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">soul dealer</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/ancient-empire-other-world">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/AncientEmpireOtherWorldthumb.jpg" alt="ANCIENT EMPIRE - Other World">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/ancient-empire-other-world">ANCIENT EMPIRE - Other World</a>
          </h5>
          <p class="story-published-on">January 24, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">ancient empire</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/devin-townsend-only-half-there">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/DevinTownsendOnlyHalfTherethumb.jpg" alt="DEVIN TOWNSEND - Only Half There">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/devin-townsend-only-half-there">DEVIN TOWNSEND - Only Half There</a>
          </h5>
          <p class="story-published-on">January 17, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">devin townsend</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/joe-giron-vulgar-display-of-pantera">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/JoeGironAVulgarDisplayOfPanterathumb.jpg" alt="JOE GIRON - Vulgar Display Of PANTERA">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/joe-giron-vulgar-display-of-pantera">JOE GIRON - Vulgar Display Of PANTERA</a>
          </h5>
          <p class="story-published-on">January 17, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">joe giron</span>
            <span class="label label-default label-gray-light">pantera</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/harley-flanagan-hard-core-life-of-my-own">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/HarleyFlanaganHard-Corethumb.jpg" alt="HARLEY FLANAGAN - Hard-Core: Life Of My Own">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/harley-flanagan-hard-core-life-of-my-own">HARLEY FLANAGAN - Hard-Core: Life Of My Own</a>
          </h5>
          <p class="story-published-on">January 17, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">cro-mags</span>
            <span class="label label-default label-gray-light">harley flanagan</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/corona-skies-fragments-of-reality">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/CoronaSkiesFragmentsOfRealitythumb.jpg" alt="CORONA SKIES - Fragments Of Reality">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/corona-skies-fragments-of-reality">CORONA SKIES - Fragments Of Reality</a>
          </h5>
          <p class="story-published-on">January 17, 2017, a month ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">corona skies</span>
          </p>
        </div>
      </li>
      <li class="story-read-more">
        <a class="btn btn-link btn-brand btn-read-more" href="http://bravewords.com/reviews">Read More</a>
      </li>
    </ul>
  </div>
</div>

</div>

  </div>
</div>


        <br clear="all">
        <div id="rcjsload_3bd255"></div>
        <script type="text/javascript">
          (function() {
            var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
            var rcel = document.createElement("script");
            rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
            rcel.type = 'text/javascript';
            rcel.src = "http://trends.revcontent.com/serve.js.php?w=44674&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
            rcel.async = true;
            var rcds = document.getElementById("rcjsload_3bd255"); rcds.appendChild(rcel);
          })();
        </script>

      </div>
    </div>
  </div>
</section>

<section id="footer" data-region="footer">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 footer">
        
  bravewords.com • <a href="/terms-and-conditions">Terms & Conditions</a>

      </div>
    </div>
  </div>
</section>

<div id="modal" class="modal" data-region="modal"></div>


    <script src="/assets-static/vendors.121dfc00550765bd7777.js"></script>
    <script src="/assets-static/app.121dfc00550765bd7777.js"></script>
    
  </body>
</html>




