<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>GLENN HUGHES Pays Tribute To KEN HENSLEY - &#34;An Incredible Songwriter, Guitarist And Keyboard Player, And More Importantly A Beautiful, Kind Human Being&#34; - BraveWords</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="news, ken hensley, uriah heep, glenn hughes, deep purple, hard rock">
    <meta name="description" content="It was reported yesterday that former Uriah Heep keyboardist Ken Hensley passed away on November 4th. The sad news was delivered on November 5th by his brother, Trevor, in a post on Facebook.
&#34;I am writing this with a heavy heart to let you know that my brother Ken Hensley...">
    <meta name="author" content="BraveWords">
    <meta name="verify-v1" content="UG2Z0A6uZRfu/o3aZh9WaxJSVUDm4RZbqJrFe/F7Mis=" />
    <meta name="alexaVerifyID" content="S1M8-AaHKAG76rKFC1bczMy8KvM" />
    <meta name="bitly-verification" content="444d87609be9" />
    
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="GLENN HUGHES Pays Tribute To KEN HENSLEY - &#34;An Incredible Songwriter, Guitarist And Keyboard Player, And More Importantly A Beautiful, Kind Human Being&#34;" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://bravewords.com/news/glenn-hughes-pays-tribute-to-ken-hensley-an-incredible-songwriter-guitarist-and-keyboard-player-and-more-importantly-a-beautiful-kind-human-being" />
<meta property="og:image" content="http://bravewords.com/medias-static/images/news/2020/5FA515E2-glenn-hughes-pays-tribute-to-ken-hensley-an-incredible-songwriter-guitarist-and-keyboard-player-and-more-importantly-a-beautiful-kind-human-being-image.jpg" />
<meta property="og:description" content="It was reported yesterday that former Uriah Heep keyboardist Ken Hensley passed away on November 4th. The sad news was delivered on November 5th by his brother, Trevor, in a post on Facebook.
&#34;I am writing this with a heavy heart to let you know that my brother Ken Hensley..." />
<meta property="og:site_name" content="bravewords.com" />
<meta property="article:publisher" content="https://www.facebook.com/bravewords" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="ken hensley" />
<meta property="article:tag" content="uriah heep" />
<meta property="article:tag" content="glenn hughes" />
<meta property="article:tag" content="deep purple" />
<meta property="article:tag" content="hard rock" />
<meta property="fb:app_id" content="684233228278895" />

    
<meta name="twitter:card" content="summary">
<meta property="twitter:url" content="http://bravewords.com/news/glenn-hughes-pays-tribute-to-ken-hensley-an-incredible-songwriter-guitarist-and-keyboard-player-and-more-importantly-a-beautiful-kind-human-being" />
<meta name="twitter:site" content="@BraveWords666">
<meta name="twitter:domain" content="bravewords.com">
<meta name="twitter:title" content="GLENN HUGHES Pays Tribute To KEN HENSLEY - &#34;An Incredible Songwriter, Guitarist And Keyboard Player, And More Importantly A Beautiful, Kind Human Being&#34;">
<meta name="twitter:description" content="It was reported yesterday that former Uriah Heep keyboardist Ken Hensley passed away on November 4th. The sad news was delivered on November 5th by his brother, Trevor, in a post on Facebook.
&#34;I am writing this with a heavy heart to let you know that my brother Ken Hensley...">
<meta name="twitter:creator" content="@BraveWords666">
<meta name="twitter:image" content="http://bravewords.com/medias-static/images/news/2020/5FA515E2-glenn-hughes-pays-tribute-to-ken-hensley-an-incredible-songwriter-guitarist-and-keyboard-player-and-more-importantly-a-beautiful-kind-human-being-image.jpg">

    <!-- Bootstrap -->
    <link href="/assets-static/vendors.0bff35fbc4d494b9cd40.css" rel="stylesheet">
    <link href="/assets-static/app.0bff35fbc4d494b9cd40.css" rel="stylesheet">
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 10]>
      <script src="//cdn.jsdelivr.net/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="//cdn.jsdelivr.net/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <link rel="shortcut icon" href="/app-static/favicon.png">
    <link rel="alternate" type="application/rss+xml" title="BraveWords RSS News Channel" href="http://bravewords.com/rss/news.xml"/>
    <link rel="alternate" type="application/rss+xml" title="BraveWords RSS Reviews Channel" href="http://bravewords.com/rss/reviews.xml"/>
    <link rel="alternate" type="application/rss+xml" title="BraveWords RSS Features Channel" href="http://bravewords.com/rss/features.xml"/>
    

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f148a0f143921a1" async="async"></script>
<script src="https://Q1MediaHydraPlatform.com/ads/video/controller.php?qid=588f5a2956c2586c325b9421&qz=1" async></script>
<script async id="aniviewJS892590094" src="https://play.aniview.com/56f146aa181f467d0a8b45c1/5b7d522c28a0616498072cbb/bravewords_Floater.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/bravewords/loader.js');
</script>
<script src="https://cdn.reignn.com/Clients/Publishers/70318/Sites/Bravewords.com/Bravewords.com.js"></script>
<script type="text/javascript">
var $BWCategory = 'news';
var $BWTags = ['news', 'ken hensley', 'uriah heep', 'glenn hughes', 'deep purple', 'hard rock'];
var $BWContentType = 'article';
var $BWTargetDomain = 'www.revolvermag.com';
</script>
<!-- Header Tag Code -->
<script data-cfasync='false' type='text/javascript'>(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "4.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d3lcz8vpax4lo2.cloudfront.net/ads-code/29ac4385-3ca7-4db1-853a-ce2ff340f9f9.js')</script>
<!-- End Header Tag Code -->

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-342765-2', 'auto');
      ga('send', 'pageview');
    </script>
    <script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//connect.facebook.net/en_US/all.js"></script>
  </head>
  <body id="root">
    <div id="pace-loader"></div>

    



<div id="bw-takeover" class="takeover"></div>

<section id="header" data-region="header">
  <div class="container container-defaults header">
    <div class="row">
      <div id="top-logo" class="col-sm-6 col-sm-offset-3">
        <div class="top-logo">
          <a href="http://bravewords.com/home">
            <img src="/assets-static/img/bravewords-350.png">
          </a>
        </div>
      </div>
      <div id="top-nav" class="col-sm-3">
        <ul class="top-nav">
          <li>
            <a href="https://www.facebook.com/bravewords">
              <i class="fa fa-facebook"></i>
            </a>
          </li>
          <li>
            <a href="https://twitter.com/bravewords666">
              <i class="fa fa-twitter"></i>
            </a>
          </li>
          <li>
            <a href="https://www.instagram.com/bravewords666">
              <i class="fa fa-instagram"></i>
            </a>
          </li>
          <li>
            <a href="https://www.youtube.com/user/BraveWords666">
              <i class="fa fa-youtube"></i>
            </a>
          </li>
        </ul>
      </div>
    </div>
    <div class="row">
      <div class="leaderboard">
        <div id="bw-leaderboard"></div>
      </div>
    </div>
  </div>
</section>

<section id="main-nav" class="afflix" data-spy="afflix">
  <div class="container container-defaults">
    <nav class="navbar navbar-inverse" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
        </button>
        <div class="navbar-brand">
          <div class="nav-logo">
            <img src="/assets-static/img/bw.png">
          </div>
        </div>
      </div>

      <!-- Collect the nav links, forms, and other content for toggling -->
      <div class="collapse navbar-collapse" id="navbar-collapse">
        <ul class="nav navbar-nav navbar-main">
          <li class=""><a href="/home">Home</a></li>
          <li class="dropdown active">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">News <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/news">Latest News</a></li>
              <li><a href="/news?t=heavy+metal">Heavy Metal</a></li>
              <li><a href="/news?t=black+death">Black Death</a></li>
              <li><a href="/news?t=hard+rock">Hard Rock</a></li>
              <li><a href="/news?t=classic+rock">Classic Rock</a></li>
              <li><a href="/news?t=riff+notes">Riff Notes</a></li>
              <li><a href="/news?t=rarities">Rarities</a></li>
            </ul>
          </li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Medias <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/galleries">Galleries</a></li>
              <li><a href="/videos">Videos</a></li>
              <li><a href="/exclusives/videos">Featured Videos</a></li>
              <li><a href="/exclusives/audios/player">Featured Audios</a></li>
              <li><a href="/metal-market">Market</a></li>
            </ul>
          </li>
          <li class=""><a href="/contests">Contests</a></li>
          <li class=""><a href="/mailing-list">Mailing List</a></li>
          <li><a href="https://streamingforvengeance.com">Streaming</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">About <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/about/contact">Contact</a></li>
              <li><a href="/about/who-we-are">Who We Are</a></li>
              <li><a href="/about/how-to-advertise">How To Advertise</a></li>
              <li><a href="https://braveboard.org">BraveBoard</a></li>
            </ul>
          </li>
        </ul>
        <ul class="nav navbar-nav navbar-right navbar-search">
          <li class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
              <i class="fa fa-search search-icon"></i>
            </a>
            <div class="dropdown-menu dropdown-search">
              <form
                class="navbar-form navbar-right"
                role="search"
                action="http://bravewords.com/search"
                >
                <div>
                  <input
                    type="text"
                    class="form-control input-md global-search"
                    name="q"
                    placeholder="SEARCH"
                    >
                </div>
              </form>
            </div>
          </li>
        </ul>
      </div>
    </nav>
  </div>
</section>

<section id="content" data-region="body">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 content">
        

<div class="row">
  <div class="col-md-8 page-content">
    <div class="clearfix">
      <h2 class="page-title">GLENN HUGHES Pays Tribute To KEN HENSLEY - &#34;An Incredible Songwriter, Guitarist And Keyboard Player, And More Importantly A Beautiful, Kind Human Being&#34;</h2>
      <p class="page-publish-on">November 6, 2020, an hour ago</p>
      <p class="page-tags">
        <span class="label label-default label-gray-light">news</span>
        <span class="label label-default label-gray-light">ken hensley</span>
        <span class="label label-default label-gray-light">uriah heep</span>
        <span class="label label-default label-gray-light">glenn hughes</span>
        <span class="label label-default label-gray-light">deep purple</span>
        <span class="label label-default label-gray-light">hard rock</span>
      </p>
      <div class="addthis_sharing_toolbox pull-right"></div>
    </div>
    <div class="page-body">
      <img class="img-responsive page-image" src="/medias-static/images/news/2020/5FA515E2-glenn-hughes-pays-tribute-to-ken-hensley-an-incredible-songwriter-guitarist-and-keyboard-player-and-more-importantly-a-beautiful-kind-human-being-image.jpg" alt="GLENN HUGHES Pays Tribute To KEN HENSLEY - &#34;An Incredible Songwriter, Guitarist And Keyboard Player, And More Importantly A Beautiful, Kind Human Being&#34;">
      <p>It was reported yesterday that former Uriah Heep keyboardist Ken Hensley passed away on November 4th. The sad news was delivered on November 5th by his brother, Trevor, in a post on Facebook.</p>

<p>"I am writing this with a heavy heart to let you know that my brother Ken Hensley passed away peacefully on Wednesday evening. His beautiful wife Monica was at his side and comforted Ken in his last few minutes with us. We are all devastated by this tragic and incredibly unexpected loss and ask that you please give us some space and time to come to terms with it. Ken will be cremated in a private ceremony in Spain so please don’t ask for information about a funeral.</p>

<p>Ken has gone but he will never be forgotten and will always be in our hearts. Stay safe out there."</p>

<p>Former Deep Purple vocalist / bassist Glenn Hughes paid tribute to his longtime friend via Instagram.</p>

<blockquote class="instagram-media" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CHOAAxpHTiH/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;">
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"> </div>

<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"> </div>

<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"> </div>
</div>
</div>

<div style="padding: 19% 0;"> </div>

<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><a href="https://www.instagram.com/p/CHOAAxpHTiH/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><svg height="50px" version="1.1" viewbox="0 0 60 60" width="50px" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#000000" transform="translate(-511.000000, -20.000000)"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></a></div>

<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"><a href="https://www.instagram.com/p/CHOAAxpHTiH/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank">Sieh dir diesen Beitrag auf Instagram an</a></div>
</div>

<div style="padding: 12.5% 0;"> </div>

<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"> </div>

<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"> </div>

<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"> </div>
</div>

<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"> </div>

<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"> </div>
</div>

<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"> </div>

<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"> </div>

<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"> </div>
</div>
</div>

<p style=" margin:8px 0 0 0; padding:0 4px;"><a href="https://www.instagram.com/p/CHOAAxpHTiH/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">So deeply saddened to hear that my long time friend & Brother, for five decades, Ken Hensley @uriahheepofficial ,has passed. An incredible songwriter, guitarist and keyboard player, and more importantly, - a beautiful kind human being. Your music will live on Ken. Honored to have sung a song called “Last Dance”on your solo album, Blood on the Highway. All my Love ...🙏🧡🕊 G</a></p>

<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">Ein Beitrag geteilt von <a href="https://www.instagram.com/glennhughesonline/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Glenn Hughes</a> (@glennhughesonline) am <time datetime="2020-11-05T18:14:42+00:00" style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;">Nov 5, 2020 um 10:14 PST</time></p>
</div>
</blockquote>
<script async src="//www.instagram.com/embed.js"></script>

<p>In what is believed to be Hensley's final interview, with eonmusic's Eamon O’Neill, Ken was asked if he ever had the desire to get back together with Uriah Heep, or was that something that just didn't interest him?</p>

<p>Said Hensley: "No. I mean, I did the reunion thing in Moscow with Mick [Box] about five or six years ago, and I was just doing it for money. That wasn't all together a pleasant experience because I expected it to be like it was in 1975 or '73 or '74, so I was crushed by my own expectations, to be perfectly honest with you.</p>

<p>"I'm perfectly happy with where I am. I may have played my last show, because the virus has killed every show that I'd planned for this year, and we're unlikely to be able to play next year. But that doesn't bother me either, because I've had such a wonderful life, and so much of my life is way beyond anything I ever dreamed I would achieve, so I can sit back and say it was great, it was fantastic, and just get on with other things. I'm just very peaceful that it happened with where I'm at, and I know that if I got on stage with Heep again, it would just be a facsimile, and I never want to be part of that."</p>

<p>Read the complete interview at <a href="https://www.eonmusic.co.uk/ken-hensley-uriah-heep-eonmusic-interview-october-2020.html" target="_blank">eonmusic.co.uk</a>.</p>

<p><iframe allow="encrypted-media" allowtransparency="true" frameborder="0" height="788" scrolling="no" src="https://www.facebook.com/plugins/post.php?href=https%3A%2F%2Fwww.facebook.com%2Ftrevor.hensley.779%2Fposts%2F10158597171891011&amp;width=600" style="border:none;overflow:hidden" width="600"></iframe></p>

      <br clear="all">
      
<br clear="all">
<div id="zergnet-widget-70729"></div>
<script language="javascript" type="text/javascript">
  (function() {
    var zergnet = document.createElement('script');
    zergnet.type = 'text/javascript'; zergnet.async = true;
    zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=70729';
    var znscr = document.getElementsByTagName('script')[0];
    znscr.parentNode.insertBefore(zergnet, znscr);
  })();
</script>

      
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

    </div>
    <div id="bw-content-box" class="bw-ads"></div>
    
<div class="disqus-widget">
  <div id="disqus_thread"></div>
</div>

  </div>
  <div class="col-md-4 shared-col">
    
<div class="shared-column">
  <div id="bw-shared-box"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Audio</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="http://bravewords.com/exclusives/audios/player">
        <img src="/medias-static/audios/2020/PhilCampbellWereTheBastards.jpeg" alt="PHIL CAMPBELL &amp; THE BASTARD SONS – “Son Of A Gun” (Nuclear Blast)" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        PHIL CAMPBELL &amp; THE BASTARD SONS – “Son Of A Gun” (Nuclear Blast)
      </h4>
    </div>
  </div>
</div>

  <div id="bw-shared-medium"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Video</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="/exclusives/videos/the-myopia-condition-separation-from-classification">
        <img src="/medias-static/audios/2020/TheMyopiaConditionEventHorizon.jpg" alt="THE MYOPIA CONDITION - &#34;Separation From Classification&#34;" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        THE MYOPIA CONDITION - &#34;Separation From Classification&#34;
      </h4>
    </div>
  </div>
  <div>
    <a class="btn btn-link btn-brand btn-read-more pull-right" href="http://bravewords.com/exclusives/videos">View More</a>
  </div>
</div>

  <div id="bw-shared-small"></div>
  
<div class="panel bw-panel stories-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Latest <span class="text-bold">Reviews</span></h3>
  </div>
  <div class="panel-body">
    <ul class="stories-list">
      <li class="story-media">
        <a class="story-left-image" href="/reviews/arapacis-deja-hard">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/AraPacisDejaHardthumb.jpg" alt="ARAPACIS - Déjà Hard">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/arapacis-deja-hard">ARAPACIS - Déjà Hard</a>
          </h5>
          <p class="story-published-on">November 4, 2020, 2 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">arapacis</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/johansson-speckmann-the-germs-of-circumstance">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/JohannsonSpeckmannTheGermsOfCircumstancethumb.jpg" alt="JOHANSSON &amp; SPECKMANN – The Germs Of Circumstance">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/johansson-speckmann-the-germs-of-circumstance">JOHANSSON &amp; SPECKMANN – The Germs Of Circumstance</a>
          </h5>
          <p class="story-published-on">November 4, 2020, 2 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">johansson &amp; speckmann</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/isenmor-shieldbrother">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/IsenmorShieldbrotherthumb.jpg" alt="ISENMOR – Shieldbrother">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/isenmor-shieldbrother">ISENMOR – Shieldbrother</a>
          </h5>
          <p class="story-published-on">November 3, 2020, 2 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">isenmor</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/inside-metal-bay-area-godfathers-part-2">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/InsideMetalBayAreaGodfathersthumb.jpg" alt="Inside Metal - Bay Area Godfathers, Part 2">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/inside-metal-bay-area-godfathers-part-2">Inside Metal - Bay Area Godfathers, Part 2</a>
          </h5>
          <p class="story-published-on">November 3, 2020, 2 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">inside metal</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/tomorrow-s-rain-hollow">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/Tomorrow&#39;sRainHollowthumb.jpg" alt="TOMORROW&#39;S RAIN - Hollow">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/tomorrow-s-rain-hollow">TOMORROW&#39;S RAIN - Hollow</a>
          </h5>
          <p class="story-published-on">November 2, 2020, 3 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">tomorrow&#39;s rain</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/proscription-conduit">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/ProscriptionConduitthumb.jpg" alt="PROSCRIPTION - Conduit">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/proscription-conduit">PROSCRIPTION - Conduit</a>
          </h5>
          <p class="story-published-on">November 2, 2020, 3 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">proscription</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/scroll-keeper-auto-da-fe">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/ScrollkeeperAutoDaFethumb.jpg" alt="SCROLL KEEPER - Auto Da Fe">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/scroll-keeper-auto-da-fe">SCROLL KEEPER - Auto Da Fe</a>
          </h5>
          <p class="story-published-on">November 1, 2020, 4 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">scroll keeper</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/messerschmitt-consumed-by-fire">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/MesserschmittConsumedByFirethumb.jpg" alt="MESSERSCHMITT - Consumed By Fire">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/messerschmitt-consumed-by-fire">MESSERSCHMITT - Consumed By Fire</a>
          </h5>
          <p class="story-published-on">October 30, 2020, 6 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">messerschmitt</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/rob-halford-confess">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/5F948D6A-rob-halford-confess-thumb.jpg" alt="ROB HALFORD - Confess ">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/rob-halford-confess">ROB HALFORD - Confess </a>
          </h5>
          <p class="story-published-on">October 24, 2020, 12 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/armored-saint-punching-the-sky">
          <img class="img-responsive" src="/medias-static/images/reviews/2020/ArmoredSaintPunchingTheSkythumb.jpg" alt="ARMORED SAINT - Punching The Sky">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/armored-saint-punching-the-sky">ARMORED SAINT - Punching The Sky</a>
          </h5>
          <p class="story-published-on">October 19, 2020, 17 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">armored saint</span>
          </p>
        </div>
      </li>
      <li class="story-read-more">
        <a class="btn btn-link btn-brand btn-read-more" href="http://bravewords.com/reviews">Read More</a>
      </li>
    </ul>
  </div>
</div>

  
<br clear="all">
<div id="insticator-container">
  <div id="div-insticator-ad-1" adonis-marker></div>
  <div id="insticator-embed" embed-id="c9e2d7ce-e545-4ad6-9ace-ef50b2853f4d"></div>
  <div id="div-insticator-ad-2" adonis-marker></div>
  <script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "c9e2d7ce-e545-4ad6-9ace-ef50b2853f4d"});/*]]>*/</script>
</div>

  <br clear="all">
</div>

  </div>
</div>

        <br clear="all">
        <div id="zergnet-widget-70730"></div>
        <script language="javascript" type="text/javascript">
          (function() {
            var zergnet = document.createElement('script');
            zergnet.type = 'text/javascript'; zergnet.async = true;
            zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=70730';
            var znscr = document.getElementsByTagName('script')[0];
            znscr.parentNode.insertBefore(zergnet, znscr);
          })();
        </script>
      </div>
    </div>
  </div>
</section>

<section id="footer" data-region="footer">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 footer">
        
  bravewords.com • <a href="/terms-and-conditions">Terms & Conditions</a>

      </div>
    </div>
  </div>
</section>

<div id="modal" class="modal" data-region="modal"></div>


    <script src="/assets-static/vendors.0bff35fbc4d494b9cd40.js"></script>
    <script src="/assets-static/app.0bff35fbc4d494b9cd40.js"></script>
    
    <!--- UNDERDOGMEDIA EDGE_BraveWords.com JavaScript ADCODE START--->
    <script data-cfasync="false" language="javascript" async src="//udmserve.net/udm/img.fetch?sid=13687;tid=1;dt=6;"></script>
    <!--- UNDERDOGMEDIA EDGE_BraveWords.com JavaScript ADCODE END--->
  </body>
</html>




