<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>BABYLON A.D. - Revelation Highway - Bravewords.com</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <meta name="keywords" content="review, hard rock, babylon a.d.">
    <meta name="description" content="California hard rockers Babylon A.D. has returned to celebrate its 30th anniversary with the release of its fourth full-length album, Revelation Highway, its first studio album in 17 years. All of its original members are here, including vocalist Derek Davis, guitarists John Mathews and Ron Freschi, drummer Jamey...">
    <meta name="author" content="bravewords.com">
    <meta name="verify-v1" content="UG2Z0A6uZRfu/o3aZh9WaxJSVUDm4RZbqJrFe/F7Mis=" />
    <meta name="alexaVerifyID" content="S1M8-AaHKAG76rKFC1bczMy8KvM" />
    <meta name="bitly-verification" content="444d87609be9" />
    
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="BABYLON A.D. - Revelation Highway" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://bravewords.com/reviews/babylon-a-d-revelation-highway" />
<meta property="og:image" content="http://bravewords.com/medias-static/images/reviews/2017/BabylonADRevelationHighway.jpg" />
<meta property="og:description" content="California hard rockers Babylon A.D. has returned to celebrate its 30th anniversary with the release of its fourth full-length album, Revelation Highway, its first studio album in 17 years. All of its original members are here, including vocalist Derek Davis, guitarists John Mathews and Ron Freschi, drummer Jamey..." />
<meta property="og:site_name" content="bravewords.com" />
<meta property="article:publisher" content="https://www.facebook.com/bravewords" />
<meta property="article:tag" content="review" />
<meta property="article:tag" content="hard rock" />
<meta property="article:tag" content="babylon a.d." />
<meta property="fb:app_id" content="684233228278895" />

    
<meta name="twitter:card" content="summary">
<meta property="twitter:url" content="http://bravewords.com/reviews/babylon-a-d-revelation-highway" />
<meta name="twitter:site" content="@BraveWords666">
<meta name="twitter:domain" content="bravewords.com">
<meta name="twitter:title" content="BABYLON A.D. - Revelation Highway">
<meta name="twitter:description" content="California hard rockers Babylon A.D. has returned to celebrate its 30th anniversary with the release of its fourth full-length album, Revelation Highway, its first studio album in 17 years. All of its original members are here, including vocalist Derek Davis, guitarists John Mathews and Ron Freschi, drummer Jamey...">
<meta name="twitter:creator" content="@BraveWords666">
<meta name="twitter:image" content="http://bravewords.com/medias-static/images/reviews/2017/BabylonADRevelationHighway.jpg">

    <!-- Bootstrap -->
    <link href="/assets-static/vendors.121dfc00550765bd7777.css" rel="stylesheet">
    <link href="/assets-static/app.121dfc00550765bd7777.css" rel="stylesheet">
    
    <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries -->
    <!--[if lt IE 10]>
      <script src="//cdn.jsdelivr.net/html5shiv/3.7.2/html5shiv.min.js"></script>
      <script src="//cdn.jsdelivr.net/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
    <link rel="shortcut icon" href="/app-static/favicon.png">
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS News Channel" href="http://bravewords.com/rss/news.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Reviews Channel" href="http://bravewords.com/rss/reviews.xml"/>
    <link rel="alternate" type="application/rss+xml" title="Bravewords.com RSS Features Channel" href="http://bravewords.com/rss/features.xml"/>
    

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f148a0f143921a1" async="async"></script>
<script src="https://Q1MediaHydraPlatform.com/ads/video/controller.php?qid=588f5a2956c2586c325b9421&qz=1" async></script>

    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
      ga('create', 'UA-342765-2', 'auto');
      ga('send', 'pageview');
    </script>
    <script type='text/javascript'>
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') +
          '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//connect.facebook.net/en_US/all.js"></script>
    <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({article:'auto'});
      !function (e, f, u) {
        e.async = 1;
        e.src = u;
        f.parentNode.insertBefore(e, f);
      }(document.createElement('script'),
      document.getElementsByTagName('script')[0],
      '//cdn.taboola.com/libtrc/bravewords/loader.js');
    </script>

  </head>
  <body id="root">
    <div id="pace-loader"></div>
    



<div id="bw-takeover" class="takeover"></div>

<section id="header" data-region="header">
  <div class="container container-defaults header">
    <div class="row">
      <div id="top-logo" class="col-sm-6 col-sm-offset-3">
        <div class="top-logo">
          <a href="http://bravewords.com/home">
            <img src="/assets-static/img/bravewords-350.png">
          </a>
        </div>
      </div>
      <div id="top-nav" class="col-sm-3">
        <ul class="top-nav">
          <li>
            <a href="https://www.facebook.com/bravewords">
              <i class="fa fa-facebook"></i>
            </a>
          </li>
          <li>
            <a href="https://twitter.com/bravewords666">
              <i class="fa fa-twitter"></i>
            </a>
          </li>
          <li>
            <a href="#">
              <i class="fa fa-youtube"></i>
            </a>
          </li>
        </ul>
      </div>
    </div>
    <div class="row">
      <div class="leaderboard">
        <div id="bw-leaderboard"></div>
      </div>
    </div>
  </div>
</section>

<section id="main-nav" class="afflix" data-spy="afflix">
  <div class="container container-defaults">
    <nav class="navbar navbar-inverse" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#navbar-collapse">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
        </button>
        <div class="navbar-brand">
          <div class="nav-logo">
            <img src="/assets-static/img/bw.png">
          </div>
        </div>
      </div>

      <!-- Collect the nav links, forms, and other content for toggling -->
      <div class="collapse navbar-collapse" id="navbar-collapse">
        <ul class="nav navbar-nav navbar-main">
          <li class=""><a href="/home">Home</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">News <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/news">Latest News</a></li>
              <li><a href="/news?t=heavy+metal">Heavy Metal</a></li>
              <li><a href="/news?t=black+death">Black Death</a></li>
              <li><a href="/news?t=hard+rock">Hard Rock</a></li>
              <li><a href="/news?t=classic+rock">Classic Rock</a></li>
              <li><a href="/news?t=riff+notes">Riff Notes</a></li>
              <li><a href="/news?t=rarities">Rarities</a></li>
            </ul>
          </li>
          <li class="active"><a href="/reviews">Reviews</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Medias <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/galleries">Galleries</a></li>
              <li><a href="/videos">Videos</a></li>
              <li><a href="/exclusives/videos">Featured Videos</a></li>
              <li><a href="/exclusives/audios/player">Featured Audios</a></li>
            </ul>
          </li>
          <li class=""><a href="/metal-market">Market</a></li>
          <li class=""><a href="http://bb.bravewords.com">Board</a></li>
          <li class="dropdown ">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">About <b class="caret"></b></a>
            <ul class="dropdown-menu">
              <li><a href="/about/contact">Contact</a></li>
              <li><a href="/about/who-we-are">Who We Are</a></li>
              <li><a href="/about/how-to-advertise">How To Advertise</a></li>
            </ul>
          </li>
        </ul>
        <ul class="nav navbar-nav navbar-right navbar-search">
          <li class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
              <i class="fa fa-search search-icon"></i>
            </a>
            <div class="dropdown-menu dropdown-search">
              <form
                class="navbar-form navbar-right"
                role="search"
                action="http://bravewords.com/search"
                >
                <div>
                  <input
                    type="text"
                    class="form-control input-md global-search"
                    name="q"
                    placeholder="SEARCH"
                    >
                </div>
              </form>
            </div>
          </li>
        </ul>
      </div>
    </nav>
  </div>
</section>

<section id="content" data-region="body">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 content">
        

<div class="row">
  <div class="col-md-8 page-content">
    <div class="clearfix">
      <h2 class="page-title">BABYLON A.D. - Revelation Highway</h2>
      <p class="page-publish-on">November 28, 2017, an hour ago</p>
      <h5 class="page-label">(Frontiers)</h5>
      <p class="page-author">Kelley Simms</p>
      <p class="page-rating">Rating: <strong>8.0</strong></p>
      <p class="page-tags">
        <span class="label label-default label-gray-light">review</span>
        <span class="label label-default label-gray-light">hard rock</span>
        <span class="label label-default label-gray-light">babylon a.d.</span>
      </p>
      <div class="addthis_sharing_toolbox pull-right"></div>
    </div>
    <div class="page-body">
      <img class="img-responsive page-image" src="/medias-static/images/reviews/2017/BabylonADRevelationHighway.jpg" alt="BABYLON A.D. - Revelation Highway">
      <p>California hard rockers Babylon A.D. has returned to celebrate its 30th anniversary with the release of its fourth full-length album, Revelation Highway, its first studio album in 17 years. All of its original members are here, including vocalist Derek Davis, guitarists John Mathews and Ron Freschi, drummer Jamey Pacheco and bassist Robb Reid. On its ten energetic tracks, the band infuses its classic hard rock/glam metal style it was known for back in the day, which possesses a timeless quality. Babylon A.D. broke out in a hurry with hits “Bang Go The Bells” and “Hammer Swings Down” from its 1989 self-titled album, which garnered decent rotation on MTVs Headbangers Ball. However, Babylon A.D. has been gone for quite a while that most folks might not be as familiar with them as some of their peers who are still at it, such as Britny Fox, KIX and Spread Eagle.</p>

<p>Opener “Crash And Burn” has a punchy, ’80s swagger, decorated with edgy Skid Row riffs and a highly-infectious chorus. Davis’s voice is still in tip-top shape after 30 years with his soulful, gritty rasp. The acoustic, Tesla-tinged intro of “Fool On Fire” soon grabs you with its soaring vocal harmonies and its memorable chorus. The catchy “One Million Miles” is further proof of what the band does so well with its highly-infectious chorus, lush vocal harmonies and memorable guitar melodies. Revelation Highway is proof that Babylon A.D. are still relevant in 2017.</p>

<p><iframe frameborder="0" marginheight="0" marginwidth="0" scrolling="no" src="//ws-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&amp;OneJS=1&amp;Operation=GetAdHtml&amp;MarketPlace=US&amp;source=ac&amp;ref=qf_sp_asin_til&amp;ad_type=product_link&amp;tracking_id=wwwbravewords-20&amp;marketplace=amazon&amp;region=US&amp;placement=B0756WHN7X&amp;asins=B0756WHN7X&amp;linkId=a9e875fc77c79280b40fc41f20a3af38&amp;show_border=true&amp;link_opens_in_new_window=true&amp;price_color=333333&amp;title_color=0066c0&amp;bg_color=ffffff" style="width:120px;height:240px;"><br />    </iframe></p>

      
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

    </div>
    <div id="bw-content-box"></div>
    
<div class="disqus-widget">
  <div id="disqus_thread"></div>
</div>

  </div>
  <div class="col-md-4 shared-col">
    
<div class="shared-column">
  <div id="bw-shared-box"></div>
  <div id="bw-clock"></div>
  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Audio</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="http://bravewords.com/exclusives/audios/player">
        <img src="/medias-static/audios/2017/RobbFinlaysonWinter&#39;sApprentice.jpeg" alt="ROBB FINLAYSON - &#34;Winter&#39;s Apprentice&#34; (Independent)" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        ROBB FINLAYSON - &#34;Winter&#39;s Apprentice&#34; (Independent)
      </h4>
    </div>
  </div>
</div>

  
<div class="panel bw-panel exclusives-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Featured <span class="text-bold">Video</span></h3>
  </div>
  <div class="panel-body">
    <div class="exclusive-content">
      <a href="/exclusives/videos/rich-davis-premiers-big-bad-wolf">
        <img src="/medias-static/audios/2017/RichDavisBigBadWolf.jpg" alt="RICH DAVIS Premiers “Big Bad Wolf”" class="img-responsive">
      </a>
      <h4 class="exclusive-title">
        RICH DAVIS Premiers “Big Bad Wolf”
      </h4>
    </div>
  </div>
  <div>
    <a class="btn btn-link btn-brand btn-read-more pull-right" href="http://bravewords.com/exclusives/videos">View More</a>
  </div>
</div>

  <div id="bw-shared-small"></div>
  
<div class="panel bw-panel stories-panel">
  <div class="panel-heading">
    <h3 class="panel-title">Latest <span class="text-bold">Reviews</span></h3>
  </div>
  <div class="panel-body">
    <ul class="stories-list">
      <li class="story-media">
        <a class="story-left-image" href="/reviews/babylon-a-d-revelation-highway">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/BabylonADRevelationHighwaythumb.jpg" alt="BABYLON A.D. - Revelation Highway">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/babylon-a-d-revelation-highway">BABYLON A.D. - Revelation Highway</a>
          </h5>
          <p class="story-published-on">November 28, 2017, an hour ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">babylon a.d.</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/stalker-shadow-of-the-sword">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/StalkerShadowOfTheSwordthumb.jpg" alt="STALKER - Shadow Of The Sword">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/stalker-shadow-of-the-sword">STALKER - Shadow Of The Sword</a>
          </h5>
          <p class="story-published-on">November 27, 2017, a day ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">stalker</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/lucifer-s-chalice-the-pact">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/Lucifer&#39;sChaliceThePactthumb.jpg" alt="LUCIFER&#39;S CHALICE - The Pact">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/lucifer-s-chalice-the-pact">LUCIFER&#39;S CHALICE - The Pact</a>
          </h5>
          <p class="story-published-on">November 27, 2017, a day ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">lucifer&#39;s chalice</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/santa-cruz-bad-blood-rising">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/SantaCruzBadBloodRisingthumb.jpg" alt="SANTA CRUZ - Bad Blood Rising">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/santa-cruz-bad-blood-rising">SANTA CRUZ - Bad Blood Rising</a>
          </h5>
          <p class="story-published-on">November 24, 2017, 3 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">santa cruz</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/lucifer-s-hammer-victory-is-mine-ep">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/Lucifer&#39;sHammerVictoryIsMinethumb.jpg" alt="LUCIFER&#39;S HAMMER - Victory Is Mine EP">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/lucifer-s-hammer-victory-is-mine-ep">LUCIFER&#39;S HAMMER - Victory Is Mine EP</a>
          </h5>
          <p class="story-published-on">November 23, 2017, 4 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">lucifer&#39;s hammer</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/ayat-carry-on-carrion">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/AyatCarryOnCarrionthumb.jpg" alt="AYAT - Carry On, Carrion">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/ayat-carry-on-carrion">AYAT - Carry On, Carrion</a>
          </h5>
          <p class="story-published-on">November 23, 2017, 5 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">ayat</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/sweet-lynch-unified">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/SweetLynchUnifiedthumb.jpg" alt="SWEET &amp; LYNCH - Unified">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/sweet-lynch-unified">SWEET &amp; LYNCH - Unified</a>
          </h5>
          <p class="story-published-on">November 22, 2017, 5 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">sweet &amp; lynch</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/threat-signal-disconnect">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/ThreatSignalDisconnectthumb.jpg" alt="THREAT SIGNAL - Disconnect">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/threat-signal-disconnect">THREAT SIGNAL - Disconnect</a>
          </h5>
          <p class="story-published-on">November 22, 2017, 6 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">threat signal</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/bruce-dickinson-what-does-this-button-do">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/BruceDickinsonBiothumb.jpg" alt="BRUCE DICKINSON - What Does This Button Do?">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/bruce-dickinson-what-does-this-button-do">BRUCE DICKINSON - What Does This Button Do?</a>
          </h5>
          <p class="story-published-on">November 21, 2017, 6 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">bruce dickinson</span>
            <span class="label label-default label-gray-light">iron maiden</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/black-sabbath-the-end">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/BlackSabbathTheEndthumb.jpg" alt="BLACK SABBATH - The End">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/black-sabbath-the-end">BLACK SABBATH - The End</a>
          </h5>
          <p class="story-published-on">November 21, 2017, 7 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">black sabbath</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/goatpenis-anesthetic-vapor">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/GoatpenisAnestheticVaporthumb.jpg" alt="GOATPENIS - Anesthetic Vapor">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/goatpenis-anesthetic-vapor">GOATPENIS - Anesthetic Vapor</a>
          </h5>
          <p class="story-published-on">November 17, 2017, 10 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">goatpenis</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/black-water-rising-electrified">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/BlackWaterRisingElectrifiedthumb.jpg" alt="BLACK WATER RISING - Electrified">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/black-water-rising-electrified">BLACK WATER RISING - Electrified</a>
          </h5>
          <p class="story-published-on">November 17, 2017, 11 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">black water rising</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/night-viper-exterminator">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/NightViperExterminatorthumb.jpg" alt="NIGHT VIPER - Exterminator">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/night-viper-exterminator">NIGHT VIPER - Exterminator</a>
          </h5>
          <p class="story-published-on">November 15, 2017, 12 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">night viper</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/serpentrance-the-besieged-sanctum">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/SerpentranceTheBesiegedSanctumthumb.jpg" alt="SERPENTRANCE - The Besieged Sanctum">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/serpentrance-the-besieged-sanctum">SERPENTRANCE - The Besieged Sanctum</a>
          </h5>
          <p class="story-published-on">November 15, 2017, 13 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">serpentrance</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/cyhra-letters-to-myself">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/CyhraLettersToMyselfthumb.jpg" alt="CYHRA - Letters To Myself">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/cyhra-letters-to-myself">CYHRA - Letters To Myself</a>
          </h5>
          <p class="story-published-on">November 14, 2017, 13 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">cyhra</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/scour-red">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/ScourRedthumb.jpg" alt="SCOUR - Red">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/scour-red">SCOUR - Red</a>
          </h5>
          <p class="story-published-on">November 14, 2017, 13 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">scour</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/communic-where-echoes-gather">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/CommunicWhereEchoesGatherthumb.jpg" alt="COMMUNIC - Where Echoes Gather">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/communic-where-echoes-gather">COMMUNIC - Where Echoes Gather</a>
          </h5>
          <p class="story-published-on">November 14, 2017, 14 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">communic</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/horrified-allure-of-the-fallen">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/HorrifiedAllureOfTheFallenthumb.jpg" alt="HORRIFIED - Allure Of The Fallen">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/horrified-allure-of-the-fallen">HORRIFIED - Allure Of The Fallen</a>
          </h5>
          <p class="story-published-on">November 10, 2017, 17 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">black death</span>
            <span class="label label-default label-gray-light">horrified</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/savage-messiah-hands-of-fate">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/SavageMessiahHandsOfFatethumb.jpg" alt="SAVAGE MESSIAH - Hands Of Fate">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/savage-messiah-hands-of-fate">SAVAGE MESSIAH - Hands Of Fate</a>
          </h5>
          <p class="story-published-on">November 10, 2017, 17 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">savage messiah</span>
          </p>
        </div>
      </li>
      <li class="story-media">
        <a class="story-left-image" href="/reviews/oz-transition-state">
          <img class="img-responsive" src="/medias-static/images/reviews/2017/OzTransitionStatethumb.jpg" alt="OZ - Transition State">
        </a>
        <div class="story-body">
          <h5 class="story-title">
            <a href="/reviews/oz-transition-state">OZ - Transition State</a>
          </h5>
          <p class="story-published-on">November 9, 2017, 18 days ago</p>
          <p>
            <span class="label label-default label-gray-light">review</span>
            <span class="label label-default label-gray-light">heavy metal</span>
            <span class="label label-default label-gray-light">hard rock</span>
            <span class="label label-default label-gray-light">oz</span>
          </p>
        </div>
      </li>
      <li class="story-read-more">
        <a class="btn btn-link btn-brand btn-read-more" href="http://bravewords.com/reviews">Read More</a>
      </li>
    </ul>
  </div>
</div>

</div>

  </div>
</div>


        <br clear="all">
        <div id="rcjsload_3bd255"></div>
        <script type="text/javascript">
          (function() {
            var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
            var rcel = document.createElement("script");
            rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
            rcel.type = 'text/javascript';
            rcel.src = "http://trends.revcontent.com/serve.js.php?w=44674&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
            rcel.async = true;
            var rcds = document.getElementById("rcjsload_3bd255"); rcds.appendChild(rcel);
          })();
        </script>

      </div>
    </div>
  </div>
</section>

<section id="footer" data-region="footer">
  <div class="container container-defaults">
    <div class="row">
      <div class="col-xs-12 footer">
        
  bravewords.com • <a href="/terms-and-conditions">Terms & Conditions</a>

      </div>
    </div>
  </div>
</section>

<div id="modal" class="modal" data-region="modal"></div>


    <script src="/assets-static/vendors.121dfc00550765bd7777.js"></script>
    <script src="/assets-static/app.121dfc00550765bd7777.js"></script>
    
  </body>
</html>




